[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240912153730.GN572255@kernel.org>
Date: Thu, 12 Sep 2024 16:37:30 +0100
From: Simon Horman <horms@...nel.org>
To: KhaiWenTan <khai.wen.tan@...ux.intel.com>
Cc: Alexandre Torgue <alexandre.torgue@...s.st.com>,
Jose Abreu <joabreu@...opsys.com>,
"David S . Miller" <davem@...emloft.net>,
Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
Maxime Coquelin <mcoquelin.stm32@...il.com>,
Xiaolei Wang <xiaolei.wang@...driver.com>, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org,
linux-stm32@...md-mailman.stormreply.com,
linux-arm-kernel@...ts.infradead.org,
Choong Yong Liang <yong.liang.choong@...ux.intel.com>,
Tan Khai Wen <khai.wen.tan@...el.com>
Subject: Re: [PATCH net 1/1] net: stmmac: Fix zero-division error when
disabling tc cbs
On Thu, Sep 12, 2024 at 09:55:41AM +0800, KhaiWenTan wrote:
> The commit b8c43360f6e4 ("net: stmmac: No need to calculate speed divider
> when offload is disabled") allows the "port_transmit_rate_kbps" to be
> set to a value of 0, which is then passed to the "div_s64" function when
> tc-cbs is disabled. This leads to a zero-division error.
>
> When tc-cbs is disabled, the idleslope, sendslope, and credit values the
> credit values are not required to be configured. Therefore, adding a return
> statement after setting the txQ mode to DCB when tc-cbs is disabled would
> prevent a zero-division error.
>
> Fixes: b8c43360f6e4 ("net: stmmac: No need to calculate speed divider when offload is disabled")
> Cc: <stable@...r.kernel.org>
> Co-developed-by: Choong Yong Liang <yong.liang.choong@...ux.intel.com>
> Signed-off-by: Choong Yong Liang <yong.liang.choong@...ux.intel.com>
> Signed-off-by: KhaiWenTan <khai.wen.tan@...ux.intel.com>
> ---
> drivers/net/ethernet/stmicro/stmmac/stmmac_tc.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/net/ethernet/stmicro/stmmac/stmmac_tc.c b/drivers/net/ethernet/stmicro/stmmac/stmmac_tc.c
> index 996f2bcd07a2..2c3fd9c66d14 100644
> --- a/drivers/net/ethernet/stmicro/stmmac/stmmac_tc.c
> +++ b/drivers/net/ethernet/stmicro/stmmac/stmmac_tc.c
> @@ -392,10 +392,10 @@ static int tc_setup_cbs(struct stmmac_priv *priv,
> } else if (!qopt->enable) {
> ret = stmmac_dma_qmode(priv, priv->ioaddr, queue,
> MTL_QUEUE_DCB);
> - if (ret)
> - return ret;
> + if (!ret)
> + priv->plat->tx_queues_cfg[queue].mode_to_use = MTL_QUEUE_DCB;
>
> - priv->plat->tx_queues_cfg[queue].mode_to_use = MTL_QUEUE_DCB;
> + return ret;
> }
Thanks,
I agree with your analysis. But I think it would
be more idomatic to write it such that the main thread
of execution is the non-error path (in any case,
it makes it easier for me to understand the intent of the code.
What I am suggesting is this (extra context provided for clarity):
diff --git a/drivers/net/ethernet/stmicro/stmmac/stmmac_tc.c b/drivers/net/ethernet/stmicro/stmmac/stmmac_tc.c
index 996f2bcd07a2..308ef4241768 100644
--- a/drivers/net/ethernet/stmicro/stmmac/stmmac_tc.c
+++ b/drivers/net/ethernet/stmicro/stmmac/stmmac_tc.c
@@ -392,14 +392,15 @@ static int tc_setup_cbs(struct stmmac_priv *priv,
} else if (!qopt->enable) {
ret = stmmac_dma_qmode(priv, priv->ioaddr, queue,
MTL_QUEUE_DCB);
if (ret)
return ret;
priv->plat->tx_queues_cfg[queue].mode_to_use = MTL_QUEUE_DCB;
+ return 0;
}
/* Final adjustments for HW */
value = div_s64(qopt->idleslope * 1024ll * ptr, port_transmit_rate_kbps);
priv->plat->tx_queues_cfg[queue].idle_slope = value & GENMASK(31, 0);
value = div_s64(-qopt->sendslope * 1024ll * ptr, port_transmit_rate_kbps);
Powered by blists - more mailing lists