[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5c905df49a332b1136787a524955b46b6153c012.camel@HansenPartnership.com>
Date: Wed, 04 Dec 2024 11:42:34 -0500
From: James Bottomley <James.Bottomley@...senPartnership.com>
To: Zijun Hu <zijun_hu@...oud.com>, Thomas Weißschuh
<thomas@...ch.de>
Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>, Uwe
Kleine-König <ukleinek@...nel.org>, "Rafael J. Wysocki"
<rafael@...nel.org>, Chun-Kuang Hu <chunkuang.hu@...nel.org>, Philipp Zabel
<p.zabel@...gutronix.de>, David Airlie <airlied@...il.com>, Simona Vetter
<simona@...ll.ch>, Matthias Brugger <matthias.bgg@...il.com>,
AngeloGioacchino Del Regno <angelogioacchino.delregno@...labora.com>, Jean
Delvare <jdelvare@...e.com>, Guenter Roeck <linux@...ck-us.net>, Martin
Tuma <martin.tuma@...iteqautomotive.com>, Mauro Carvalho Chehab
<mchehab@...nel.org>, Andreas Noever <andreas.noever@...il.com>, Michael
Jamet <michael.jamet@...el.com>, Mika Westerberg
<mika.westerberg@...ux.intel.com>, Yehezkel Bernat
<YehezkelShB@...il.com>, Linus Walleij <linus.walleij@...aro.org>, Bartosz
Golaszewski <brgl@...ev.pl>, Andrew Lunn <andrew@...n.ch>, Vladimir Oltean
<olteanv@...il.com>, "David S. Miller" <davem@...emloft.net>, Eric Dumazet
<edumazet@...gle.com>, Jakub Kicinski <kuba@...nel.org>, Paolo Abeni
<pabeni@...hat.com>, Simon Horman <horms@...nel.org>, Dan Williams
<dan.j.williams@...el.com>, Vishal Verma <vishal.l.verma@...el.com>, Dave
Jiang <dave.jiang@...el.com>, Ira Weiny <ira.weiny@...el.com>, Takashi
Sakamoto <o-takashi@...amocchi.jp>, Jiri Slaby <jirislaby@...nel.org>,
Heikki Krogerus <heikki.krogerus@...ux.intel.com>, Srinivas Kandagatla
<srinivas.kandagatla@...aro.org>, Lee Duncan <lduncan@...e.com>, Chris
Leech <cleech@...hat.com>, Mike Christie <michael.christie@...cle.com>,
"Martin K. Petersen" <martin.petersen@...cle.com>, Nilesh Javali
<njavali@...vell.com>, Manish Rangankar <mrangankar@...vell.com>,
GR-QLogic-Storage-Upstream@...vell.com, Davidlohr Bueso
<dave@...olabs.net>, Jonathan Cameron <jonathan.cameron@...wei.com>, Alison
Schofield <alison.schofield@...el.com>, Andreas Larsson
<andreas@...sler.com>, Stuart Yoder <stuyoder@...il.com>, Laurentiu Tudor
<laurentiu.tudor@....com>, Jens Axboe <axboe@...nel.dk>, Sudeep Holla
<sudeep.holla@....com>, Cristian Marussi <cristian.marussi@....com>, Ard
Biesheuvel <ardb@...nel.org>, Bjorn Andersson <andersson@...nel.org>,
Mathieu Poirier <mathieu.poirier@...aro.org>,
linux-kernel@...r.kernel.org, dri-devel@...ts.freedesktop.org,
linux-mediatek@...ts.infradead.org, linux-arm-kernel@...ts.infradead.org,
linux-hwmon@...r.kernel.org, linux-media@...r.kernel.org,
linux-usb@...r.kernel.org, linux-gpio@...r.kernel.org,
netdev@...r.kernel.org, linux-pwm@...r.kernel.org, nvdimm@...ts.linux.dev,
linux1394-devel@...ts.sourceforge.net, linux-serial@...r.kernel.org,
linux-sound@...r.kernel.org, open-iscsi@...glegroups.com,
linux-scsi@...r.kernel.org, linux-cxl@...r.kernel.org,
sparclinux@...r.kernel.org, linux-block@...r.kernel.org,
arm-scmi@...r.kernel.org, linux-efi@...r.kernel.org,
linux-remoteproc@...r.kernel.org, Zijun Hu <quic_zijuhu@...cinc.com>
Subject: Re: [PATCH v2 00/32] driver core: Constify API device_find_child()
and adapt for various existing usages
On Wed, 2024-12-04 at 20:26 +0800, Zijun Hu wrote:
> On 2024/12/3 23:34, James Bottomley wrote:
> > > > This also enables an incremental migration.
> > > change the API prototype from:
> > > device_find_child(..., void *data_0, int (*match)(struct device
> > > *dev, void *data));
> > >
> > > to:
> > > device_find_child(..., const void *data_0, int (*match)(struct
> > > device *dev, const void *data));
> > >
> > > For @data_0, void * -> const void * is okay.
> > > but for @match, the problem is function pointer type
> > > incompatibility.
> > >
> > > there are two solutions base on discussions.
> > >
> > > 1) squashing likewise Greg mentioned.
> > > Do all of the "prep work" first, and then
> > > do the const change at the very end, all at once.
> > >
> > > 2) as changing platform_driver's remove() prototype.
> > > Commit: e70140ba0d2b ("Get rid of 'remove_new' relic from
> > > platform driver struct")
> > >
> > > introduce extra device_find_child_new() which is constified ->
> > > use *_new() replace ALL device_find_child() instances one by one
> > > -> remove device_find_child() -> rename *_new() to
> > > device_find_child() once.
> > Why bother with the last step, which churns the entire code base
> > again?
>
> keep the good API name device_find_child().
Well, I think it's a good opportunity to rename the API better, but if
that's the goal, you can still do it with _Generic() without churning
the code base a second time. The example is in
slab.h:kmem_cache_create
> > Why not call the new function device_find_child_const() and simply
> > keep it (it's descriptive of its function). That way you can have
> > a patch series without merging and at the end simply remove the old
> > function.
>
> device_find_child is a good name for the API, 'find' already means
> const.
Not to me it doesn't, but that's actually not what I think is wrong
with the API name: it actually only returns the first match, so I'd
marginally prefer it to be called device_find_first_child() ... not
enough to churn the code to change it, but since you're doing that
anyway it might make sense as an update.
Regards,
James
Powered by blists - more mailing lists