[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20250210-arm_fix_selftest-v2-0-ba84b5bc58c8@debian.org>
Date: Mon, 10 Feb 2025 03:56:12 -0800
From: Breno Leitao <leitao@...ian.org>
To: "David S. Miller" <davem@...emloft.net>,
Eric Dumazet <edumazet@...gle.com>, Jakub Kicinski <kuba@...nel.org>,
Paolo Abeni <pabeni@...hat.com>, Simon Horman <horms@...nel.org>,
Andrew Lunn <andrew+netdev@...n.ch>
Cc: linux-kernel@...r.kernel.org, netdev@...r.kernel.org,
Breno Leitao <leitao@...ian.org>, kernel-team@...a.com, kuniyu@...zon.com,
ushankar@...estorage.com
Subject: [PATCH net-next v2 0/2] net: core: improvements to device lookup
by hardware address.
The first patch adds a new dev_getbyhwaddr() helper function for
finding devices by hardware address when the RTNL lock is held. This
prevents PROVE_LOCKING warnings that occurred when RTNL was held but the
RCU read lock wasn't. The common address comparison logic is extracted
into dev_comp_addr() to avoid code duplication.
The second patch adds missing documentation for the return value of
dev_getbyhwaddr_rcu(), fixing a warning reported by NIPA. The kdoc
comment now properly specifies that the function returns either a
pointer to net_device or NULL when no matching device is found.
Signed-off-by: Breno Leitao <leitao@...ian.org>
---
Changes in v2:
- Fixed the documentation (Jakub)
- Renamed the function from dev_getbyhwaddr_rtnl() to dev_getbyhwaddr()
(Jakub)
- Exported the function in the header (Jakub)
- Link to v1: https://lore.kernel.org/r/20250207-arm_fix_selftest-v1-1-487518d2fd1c@debian.org
---
Breno Leitao (2):
net: document return value of dev_getbyhwaddr_rcu()
net: Add dev_getbyhwaddr_rtnl() helper
include/linux/netdevice.h | 2 ++
net/core/dev.c | 38 ++++++++++++++++++++++++++++++++++----
2 files changed, 36 insertions(+), 4 deletions(-)
---
base-commit: 0d5248724ed8bc68c867c4c65dda625277f68fbc
change-id: 20250207-arm_fix_selftest-ee29dbc33a06
Best regards,
--
Breno Leitao <leitao@...ian.org>
Powered by blists - more mailing lists