[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <Z60mWzm0gkMlKNEe@shell.armlinux.org.uk>
Date: Wed, 12 Feb 2025 22:53:15 +0000
From: "Russell King (Oracle)" <linux@...linux.org.uk>
To: Andrew Lunn <andrew@...n.ch>
Cc: Gerhard Engleder <gerhard@...leder-embedded.com>, hkallweit1@...il.com,
davem@...emloft.net, edumazet@...gle.com, kuba@...nel.org,
pabeni@...hat.com, netdev@...r.kernel.org,
Oleksij Rempel <o.rempel@...gutronix.de>
Subject: Re: [PATCH net-next v6 6/7] net: selftests: Export
net_test_phy_loopback_*
On Wed, Feb 12, 2025 at 11:34:14PM +0100, Andrew Lunn wrote:
> It might however be that we cannot rename reserved, it is now part of
> the kAPI, and changing it to another name would break the compilation
> of something. That is one of the advantages of netlink API, you can
> add new attributes without having to worry about breaking older
> builds. Unfortunately, the self test is still using the IOCTL, it has
> not been converted to netlink.
If you wanted to introduce "speed" where "reserved" is, then could be
done is:
struct ethtool_test {
__u32 cmd;
__u32 flags;
union {
__u32 reserved;
__u32 speed;
};
__u32 len;
__u64 data[];
};
That would mean anyone assigning to ethtool_test.reserved would still
continue to work as the union is anonymous.
--
RMK's Patch system: https://www.armlinux.org.uk/developer/patches/
FTTP is here! 80Mbps down 10Mbps up. Decent connectivity at last!
Powered by blists - more mailing lists