[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20250213-arm_fix_selftest-v4-0-26714529a6cf@debian.org>
Date: Thu, 13 Feb 2025 04:42:36 -0800
From: Breno Leitao <leitao@...ian.org>
To: "David S. Miller" <davem@...emloft.net>,
Eric Dumazet <edumazet@...gle.com>, Jakub Kicinski <kuba@...nel.org>,
Paolo Abeni <pabeni@...hat.com>, Simon Horman <horms@...nel.org>,
Andrew Lunn <andrew+netdev@...n.ch>, David Ahern <dsahern@...nel.org>
Cc: linux-kernel@...r.kernel.org, netdev@...r.kernel.org,
Eric Dumazet <eric.dumazet@...il.com>, Breno Leitao <leitao@...ian.org>,
kuniyu@...zon.co.jp, ushankar@...estorage.com, kuniyu@...zon.com
Subject: [PATCH net v4 0/2] net: core: improvements to device lookup by
hardware address.
The first patch adds a new dev_getbyhwaddr() helper function for
finding devices by hardware address when the rtnl lock is held. This
prevents PROVE_LOCKING warnings that occurred when rtnl lock was held
but the RCU read lock wasn't. The common address comparison logic is
extracted into dev_comp_addr() to avoid code duplication.
The second coverts arp_req_set_public() to the new helper.
Signed-off-by: Breno Leitao <leitao@...ian.org>
---
Changes in v4:
- Split the patchset in two, and now targeting `net` instead of
`net-next` (Kuniyuki Iwashima)
- Identended the kernel-doc in the new way. The other functions will
come in a separate patchset. (Kuniyuki Iwashima)
- Link to v3: https://lore.kernel.org/r/20250212-arm_fix_selftest-v3-0-72596cb77e44@debian.org
Changes in v3:
- Fixed the cover letter (Kuniyuki Iwashima)
- Added a third patch converting arp_req_set_public() to the new helper
(Kuniyuki Iwashima)
- Link to v2:
https://lore.kernel.org/r/20250210-arm_fix_selftest-v2-0-ba84b5bc58c8@debian.org
Changes in v2:
- Fixed the documentation (Jakub)
- Renamed the function from dev_getbyhwaddr_rtnl() to dev_getbyhwaddr()
(Jakub)
- Exported the function in the header (Jakub)
- Link to v1: https://lore.kernel.org/r/20250207-arm_fix_selftest-v1-1-487518d2fd1c@debian.org
---
Breno Leitao (2):
net: Add non-RCU dev_getbyhwaddr() helper
arp: switch to dev_getbyhwaddr() in arp_req_set_public()
include/linux/netdevice.h | 2 ++
net/core/dev.c | 37 ++++++++++++++++++++++++++++++++++---
net/ipv4/arp.c | 2 +-
3 files changed, 37 insertions(+), 4 deletions(-)
---
base-commit: 0469b410c888414c3505d8d2b5814eb372404638
change-id: 20250207-arm_fix_selftest-ee29dbc33a06
Best regards,
--
Breno Leitao <leitao@...ian.org>
Powered by blists - more mailing lists