[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <b5236ae4-7ebe-4a88-bbc9-3b9b3374de53@kernel.org>
Date: Wed, 26 Feb 2025 08:14:14 +0100
From: Jiri Slaby <jirislaby@...nel.org>
To: Kuan-Wei Chiu <visitorckw@...il.com>, Yury Norov <yury.norov@...il.com>
Cc: tglx@...utronix.de, mingo@...hat.com, bp@...en8.de,
dave.hansen@...ux.intel.com, x86@...nel.org, jk@...abs.org, joel@....id.au,
eajames@...ux.ibm.com, andrzej.hajda@...el.com, neil.armstrong@...aro.org,
rfoss@...nel.org, maarten.lankhorst@...ux.intel.com, mripard@...nel.org,
tzimmermann@...e.de, airlied@...il.com, simona@...ll.ch,
dmitry.torokhov@...il.com, mchehab@...nel.org, awalls@...metrocast.net,
hverkuil@...all.nl, miquel.raynal@...tlin.com, richard@....at,
vigneshr@...com, louis.peens@...igine.com, andrew+netdev@...n.ch,
davem@...emloft.net, edumazet@...gle.com, pabeni@...hat.com,
parthiban.veerasooran@...rochip.com, arend.vanspriel@...adcom.com,
johannes@...solutions.net, gregkh@...uxfoundation.org,
akpm@...ux-foundation.org, hpa@...or.com, alistair@...ple.id.au,
linux@...musvillemoes.dk, Laurent.pinchart@...asonboard.com,
jonas@...boo.se, jernej.skrabec@...il.com, kuba@...nel.org,
linux-kernel@...r.kernel.org, linux-fsi@...ts.ozlabs.org,
dri-devel@...ts.freedesktop.org, linux-input@...r.kernel.org,
linux-media@...r.kernel.org, linux-mtd@...ts.infradead.org,
oss-drivers@...igine.com, netdev@...r.kernel.org,
linux-wireless@...r.kernel.org, brcm80211@...ts.linux.dev,
brcm80211-dev-list.pdl@...adcom.com, linux-serial@...r.kernel.org,
bpf@...r.kernel.org, jserv@...s.ncku.edu.tw,
Yu-Chun Lin <eleanor15x@...il.com>
Subject: Re: [PATCH 02/17] bitops: Add generic parity calculation for u64
On 25. 02. 25, 14:29, Kuan-Wei Chiu wrote:
>> +#define parity(val) \
>> +({ \
>> + u64 __v = (val); \
>> + int __ret; \
>> + switch (BITS_PER_TYPE(val)) { \
>> + case 64: \
>> + __v ^= __v >> 32; \
>> + fallthrough; \
>> + case 32: \
>> + __v ^= __v >> 16; \
>> + fallthrough; \
>> + case 16: \
>> + __v ^= __v >> 8; \
>> + fallthrough; \
>> + case 8: \
>> + __v ^= __v >> 4; \
>> + __ret = (0x6996 >> (__v & 0xf)) & 1; \
>> + break; \
>> + default: \
>> + BUILD_BUG(); \
>> + } \
>> + __ret; \
>> +})
>> +
>> +#define parity8(val) parity((u8)(val))
>> +#define parity32(val) parity((u32)(val))
>> +#define parity64(val) parity((u64)(val))
>>
> What do you think about using these inline functions instead of macros?
> Except for parity8(), each function is a single line and follows the
> same logic. I find inline functions more readable, and coding-style.rst
> also recommends them over macros.
Not in cases where macros are inevitable. I mean, do we need parityXX()
for XX in (8, 16, 32, 64) at all? Isn't the parity() above enough for
everybody? And if not, you can have all those parityXX() as inlines as
you suggest, but also provide a macro such as the above to call
(optimized) parityXX() as per datatype len.
thanks,
--
js
suse labs
Powered by blists - more mailing lists