[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Z/a5Qh/OeLT8JBS4@visitorckw-System-Product-Name>
Date: Thu, 10 Apr 2025 02:15:30 +0800
From: Kuan-Wei Chiu <visitorckw@...il.com>
To: Yury Norov <yury.norov@...il.com>
Cc: tglx@...utronix.de, mingo@...hat.com, bp@...en8.de,
dave.hansen@...ux.intel.com, x86@...nel.org, jk@...abs.org,
joel@....id.au, eajames@...ux.ibm.com, andrzej.hajda@...el.com,
neil.armstrong@...aro.org, rfoss@...nel.org,
maarten.lankhorst@...ux.intel.com, mripard@...nel.org,
tzimmermann@...e.de, airlied@...il.com, simona@...ll.ch,
dmitry.torokhov@...il.com, mchehab@...nel.org,
awalls@...metrocast.net, hverkuil@...all.nl,
miquel.raynal@...tlin.com, richard@....at, vigneshr@...com,
louis.peens@...igine.com, andrew+netdev@...n.ch,
davem@...emloft.net, edumazet@...gle.com, pabeni@...hat.com,
parthiban.veerasooran@...rochip.com, arend.vanspriel@...adcom.com,
johannes@...solutions.net, gregkh@...uxfoundation.org,
jirislaby@...nel.org, akpm@...ux-foundation.org, jdelvare@...e.com,
linux@...ck-us.net, alexandre.belloni@...tlin.com, pgaj@...ence.com,
hpa@...or.com, alistair@...ple.id.au, linux@...musvillemoes.dk,
Laurent.pinchart@...asonboard.com, jonas@...boo.se,
jernej.skrabec@...il.com, kuba@...nel.org,
linux-kernel@...r.kernel.org, linux-fsi@...ts.ozlabs.org,
dri-devel@...ts.freedesktop.org, linux-input@...r.kernel.org,
linux-media@...r.kernel.org, linux-mtd@...ts.infradead.org,
oss-drivers@...igine.com, netdev@...r.kernel.org,
linux-wireless@...r.kernel.org, brcm80211@...ts.linux.dev,
brcm80211-dev-list.pdl@...adcom.com, linux-serial@...r.kernel.org,
bpf@...r.kernel.org, jserv@...s.ncku.edu.tw, Frank.Li@....com,
linux-hwmon@...r.kernel.org, linux-i3c@...ts.infradead.org,
david.laight.linux@...il.com, andrew.cooper3@...rix.com,
Yu-Chun Lin <eleanor15x@...il.com>
Subject: Re: [PATCH v4 00/13] Introduce parity_odd() and refactor redundant
parity code
On Wed, Apr 09, 2025 at 12:54:35PM -0400, Yury Norov wrote:
> On Wed, Apr 09, 2025 at 11:43:43PM +0800, Kuan-Wei Chiu wrote:
> > Several parts of the kernel contain open-coded and redundant
> > implementations of parity calculation. This patch series introduces
> > a unified helper, parity_odd(), to simplify and standardize these
> > cases.
> >
> > The first patch renames parity8() to parity_odd(), changes its argument
>
> Alright, if it's an extension of the area of applicability, it should be
> renamed to just parity(). I already shared a table that summarized the
> drivers authors' view on that, and they clearly prefer not to add the
> suffix - 13 vs 2. The __builtin_parity() doesn't care of suffix as well.
>
> https://lore.kernel.org/all/Z9GtcNJie8TRKywZ@thinkpad/
>
> Yes, the argument that boolean function should explain itself sounds
> correct, but in this case, comment on top of the function looks enough
> to me.
>
> The existing codebase doesn't care about the suffix as well. If no
> strong preference, let's just pick a short and sweet name?
>
I don't have a strong preference for the name, but if I had to guess
the return value from the function prototype, I would intuitively
expect an int to return "0 for even and 1 for odd," and a bool to
return "true for even, false for odd." I recall Jiri and Jacob shared
similar thoughts, which is why I felt adding _odd could provide better
clarity.
However, I agree that if the kernel doc comment is clear, it might not
be a big issue. But David previously mentioned that he doesn't want to
rely on checking the function's documentation every time while reading
the code.
Regardless, I'm flexible as long as we all reach a consensus on the
naming.
> > type from u8 to u64 for broader applicability, and updates its return
> > type from int to bool to make its usage and return semantics more
> > intuitive-returning true for odd parity and false for even parity. It
> > also adds __attribute_const__ to enable compiler optimizations.
>
> That's correct and nice, but can you support it with a bloat-o-meter's
> before/after and/or asm snippets? I also think it worth to be a separate
> patch, preferably the last patch in the series.
>
I quickly tested it with the x86 defconfig, and it appears that the
generated code doesn't change. I forgot who requested the addition
during the review process, but I initially thought it would either
improve the generated code or leave it unchanged without significantly
increasing the source code size.
However, if there's no actual difference in the generated code, maybe
let's just remove it?
Regards,
Kuan-Wei
> > While more efficient implementations may exist, further optimization is
> > postponed until a use case in performance-critical paths arises.
> >
> > Subsequent patches refactor various kernel components to replace
> > open-coded parity logic with the new helper, reducing code duplication
> > and improving consistency.
> >
> > Co-developed-by: Yu-Chun Lin <eleanor15x@...il.com>
> > Signed-off-by: Yu-Chun Lin <eleanor15x@...il.com>
> > Signed-off-by: Kuan-Wei Chiu <visitorckw@...il.com>
> > ---
> >
> > To H. Peter:
> > I understand your preference for a parity8/16/32/64() style interface,
> > and I agree that such a design would better accommodate potential
> > arch-specific implementations. However, I suspect there are very few,
> > if any, users who care about the performance of parity calculations
> > enough to warrant such optimizations. So my inclination is to defer any
> > arch-specific or optimized implementations until we see parity_odd()
> > being used in hot paths.
> >
> > Changes in v4:
> > - Rename parity8() to parity_odd().
> > - Change the argument type from u8 to u64.
> > - Use a single parity_odd() function.
> >
> > Changes in v3:
> > - Avoid using __builtin_parity.
> > - Change return type to bool.
> > - Drop parity() macro.
> > - Change parityXX() << y to !!parityXX() << y.
> >
> > Changes in v2:
> > - Provide fallback functions for __builtin_parity() when the compiler
> > decides not to inline it
> > - Use __builtin_parity() when no architecture-specific implementation
> > is available
> > - Optimize for constant folding when val is a compile-time constant
> > - Add a generic parity() macro
> > - Drop the x86 bootflag conversion patch since it has been merged into
> > the tip tree
> >
> > v3: https://lore.kernel.org/lkml/20250306162541.2633025-1-visitorckw@gmail.com/
> > v1: https://lore.kernel.org/lkml/20250223164217.2139331-1-visitorckw@gmail.com/
> > v2: https://lore.kernel.org/lkml/20250301142409.2513835-1-visitorckw@gmail.com/
> >
> > Kuan-Wei Chiu (13):
> > bitops: Change parity8() to parity_odd() with u64 input and bool
> > return type
> > media: media/test_drivers: Replace open-coded parity calculation with
> > parity_odd()
> > media: pci: cx18-av-vbi: Replace open-coded parity calculation with
> > parity_odd()
> > media: saa7115: Replace open-coded parity calculation with
> > parity_odd()
> > serial: max3100: Replace open-coded parity calculation with
> > parity_odd()
> > lib/bch: Replace open-coded parity calculation with parity_odd()
> > Input: joystick - Replace open-coded parity calculation with
> > parity_odd()
> > net: ethernet: oa_tc6: Replace open-coded parity calculation with
> > parity_odd()
> > wifi: brcm80211: Replace open-coded parity calculation with
> > parity_odd()
> > drm/bridge: dw-hdmi: Replace open-coded parity calculation with
> > parity_odd()
> > mtd: ssfdc: Replace open-coded parity calculation with parity_odd()
> > fsi: i2cr: Replace open-coded parity calculation with parity_odd()
> > nfp: bpf: Replace open-coded parity calculation with parity_odd()
> >
> > arch/x86/kernel/bootflag.c | 4 +--
> > drivers/fsi/fsi-master-i2cr.c | 20 +++------------
> > .../drm/bridge/synopsys/dw-hdmi-ahb-audio.c | 8 ++----
> > drivers/hwmon/spd5118.c | 2 +-
> > drivers/i3c/master/dw-i3c-master.c | 2 +-
> > drivers/i3c/master/i3c-master-cdns.c | 2 +-
> > drivers/i3c/master/mipi-i3c-hci/dat_v1.c | 2 +-
> > drivers/input/joystick/grip_mp.c | 17 ++-----------
> > drivers/input/joystick/sidewinder.c | 25 ++++---------------
> > drivers/media/i2c/saa7115.c | 12 ++-------
> > drivers/media/pci/cx18/cx18-av-vbi.c | 12 ++-------
> > .../media/test-drivers/vivid/vivid-vbi-gen.c | 8 ++----
> > drivers/mtd/ssfdc.c | 20 +++------------
> > drivers/net/ethernet/netronome/nfp/nfp_asm.c | 7 +-----
> > drivers/net/ethernet/oa_tc6.c | 19 +++-----------
> > .../broadcom/brcm80211/brcmsmac/dma.c | 18 ++-----------
> > drivers/tty/serial/max3100.c | 3 ++-
> > include/linux/bitops.h | 19 ++++++++------
> > lib/bch.c | 14 +----------
> > 19 files changed, 49 insertions(+), 165 deletions(-)
>
> OK, now it looks like a nice consolidation and simplification of code
> base. Thanks for the work.
>
> Thanks,
> Yury
Powered by blists - more mailing lists