[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Z/a82sdjEDaqE9v0@visitorckw-System-Product-Name>
Date: Thu, 10 Apr 2025 02:30:50 +0800
From: Kuan-Wei Chiu <visitorckw@...il.com>
To: Yury Norov <yury.norov@...il.com>
Cc: tglx@...utronix.de, mingo@...hat.com, bp@...en8.de,
dave.hansen@...ux.intel.com, x86@...nel.org, jk@...abs.org,
joel@....id.au, eajames@...ux.ibm.com, andrzej.hajda@...el.com,
neil.armstrong@...aro.org, rfoss@...nel.org,
maarten.lankhorst@...ux.intel.com, mripard@...nel.org,
tzimmermann@...e.de, airlied@...il.com, simona@...ll.ch,
dmitry.torokhov@...il.com, mchehab@...nel.org,
awalls@...metrocast.net, hverkuil@...all.nl,
miquel.raynal@...tlin.com, richard@....at, vigneshr@...com,
louis.peens@...igine.com, andrew+netdev@...n.ch,
davem@...emloft.net, edumazet@...gle.com, pabeni@...hat.com,
parthiban.veerasooran@...rochip.com, arend.vanspriel@...adcom.com,
johannes@...solutions.net, gregkh@...uxfoundation.org,
jirislaby@...nel.org, akpm@...ux-foundation.org, jdelvare@...e.com,
linux@...ck-us.net, alexandre.belloni@...tlin.com, pgaj@...ence.com,
hpa@...or.com, alistair@...ple.id.au, linux@...musvillemoes.dk,
Laurent.pinchart@...asonboard.com, jonas@...boo.se,
jernej.skrabec@...il.com, kuba@...nel.org,
linux-kernel@...r.kernel.org, linux-fsi@...ts.ozlabs.org,
dri-devel@...ts.freedesktop.org, linux-input@...r.kernel.org,
linux-media@...r.kernel.org, linux-mtd@...ts.infradead.org,
oss-drivers@...igine.com, netdev@...r.kernel.org,
linux-wireless@...r.kernel.org, brcm80211@...ts.linux.dev,
brcm80211-dev-list.pdl@...adcom.com, linux-serial@...r.kernel.org,
bpf@...r.kernel.org, jserv@...s.ncku.edu.tw, Frank.Li@....com,
linux-hwmon@...r.kernel.org, linux-i3c@...ts.infradead.org,
david.laight.linux@...il.com, andrew.cooper3@...rix.com,
Yu-Chun Lin <eleanor15x@...il.com>
Subject: Re: [PATCH v4 05/13] serial: max3100: Replace open-coded parity
calculation with parity_odd()
On Wed, Apr 09, 2025 at 01:24:08PM -0400, Yury Norov wrote:
> On Wed, Apr 09, 2025 at 11:43:48PM +0800, Kuan-Wei Chiu wrote:
> > Refactor parity calculations to use the standard parity_odd() helper.
> > This change eliminates redundant implementations.
> >
> > Co-developed-by: Yu-Chun Lin <eleanor15x@...il.com>
> > Signed-off-by: Yu-Chun Lin <eleanor15x@...il.com>
> > Signed-off-by: Kuan-Wei Chiu <visitorckw@...il.com>
> > ---
> > drivers/tty/serial/max3100.c | 3 ++-
> > 1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/drivers/tty/serial/max3100.c b/drivers/tty/serial/max3100.c
> > index f2dd83692b2c..36ed41eef7b1 100644
> > --- a/drivers/tty/serial/max3100.c
> > +++ b/drivers/tty/serial/max3100.c
> > @@ -16,6 +16,7 @@
> > /* 4 MAX3100s should be enough for everyone */
> > #define MAX_MAX3100 4
> >
> > +#include <linux/bitops.h>
> > #include <linux/container_of.h>
> > #include <linux/delay.h>
> > #include <linux/device.h>
> > @@ -133,7 +134,7 @@ static int max3100_do_parity(struct max3100_port *s, u16 c)
> > else
> > c &= 0xff;
> >
> > - parity = parity ^ (hweight8(c) & 1);
> > + parity = parity ^ parity_odd(c);
>
> This can be simplified for more unless I misunderstand something...
>
I usually don't change the existing coding style since each subsystem
may have its own preferred style.
But yeah, if this is the preferred way, I can make this change in the
next version.
Regards,
Kuan-Wei
> From: Yury Norov <yury.norov@...il.com>
> Date: Wed Apr 9 13:22:04 2025 -0400
>
> serial: max3100: Replace open-coded parity
>
> diff --git a/drivers/tty/serial/max3100.c b/drivers/tty/serial/max3100.c
> index f2dd83692b2c..07d332b8e87d 100644
> --- a/drivers/tty/serial/max3100.c
> +++ b/drivers/tty/serial/max3100.c
> @@ -121,20 +121,12 @@ static DEFINE_MUTEX(max3100s_lock); /* race on probe */
>
> static int max3100_do_parity(struct max3100_port *s, u16 c)
> {
> - int parity;
> -
> - if (s->parity & MAX3100_PARITY_ODD)
> - parity = 1;
> - else
> - parity = 0;
> -
> if (s->parity & MAX3100_7BIT)
> c &= 0x7f;
> else
> c &= 0xff;
>
> - parity = parity ^ (hweight8(c) & 1);
> - return parity;
> + return s->parity & MAX3100_PARITY_ODD ? !parity(c) : parity(c);
> }
>
> static int max3100_check_parity(struct max3100_port *s, u16 c)
Powered by blists - more mailing lists