[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <25b7888d-f704-493b-a2d7-c5e8fff9cfb4@broadcom.com>
Date: Wed, 9 Apr 2025 20:43:09 +0200
From: Arend van Spriel <arend.vanspriel@...adcom.com>
To: Kuan-Wei Chiu <visitorckw@...il.com>, tglx@...utronix.de,
mingo@...hat.com, bp@...en8.de, dave.hansen@...ux.intel.com, x86@...nel.org,
jk@...abs.org, joel@....id.au, eajames@...ux.ibm.com,
andrzej.hajda@...el.com, neil.armstrong@...aro.org, rfoss@...nel.org,
maarten.lankhorst@...ux.intel.com, mripard@...nel.org, tzimmermann@...e.de,
airlied@...il.com, simona@...ll.ch, dmitry.torokhov@...il.com,
mchehab@...nel.org, awalls@...metrocast.net, hverkuil@...all.nl,
miquel.raynal@...tlin.com, richard@....at, vigneshr@...com,
louis.peens@...igine.com, andrew+netdev@...n.ch, davem@...emloft.net,
edumazet@...gle.com, pabeni@...hat.com, parthiban.veerasooran@...rochip.com,
johannes@...solutions.net, gregkh@...uxfoundation.org, jirislaby@...nel.org,
yury.norov@...il.com, akpm@...ux-foundation.org, jdelvare@...e.com,
linux@...ck-us.net, alexandre.belloni@...tlin.com, pgaj@...ence.com
Cc: hpa@...or.com, alistair@...ple.id.au, linux@...musvillemoes.dk,
Laurent.pinchart@...asonboard.com, jonas@...boo.se,
jernej.skrabec@...il.com, kuba@...nel.org, linux-kernel@...r.kernel.org,
linux-fsi@...ts.ozlabs.org, dri-devel@...ts.freedesktop.org,
linux-input@...r.kernel.org, linux-media@...r.kernel.org,
linux-mtd@...ts.infradead.org, oss-drivers@...igine.com,
netdev@...r.kernel.org, linux-wireless@...r.kernel.org,
brcm80211@...ts.linux.dev, brcm80211-dev-list.pdl@...adcom.com,
linux-serial@...r.kernel.org, bpf@...r.kernel.org, jserv@...s.ncku.edu.tw,
Frank.Li@....com, linux-hwmon@...r.kernel.org,
linux-i3c@...ts.infradead.org, david.laight.linux@...il.com,
andrew.cooper3@...rix.com, Yu-Chun Lin <eleanor15x@...il.com>
Subject: Re: [PATCH v4 03/13] media: pci: cx18-av-vbi: Replace open-coded
parity calculation with parity_odd()
On 4/9/2025 5:43 PM, Kuan-Wei Chiu wrote:
> Refactor parity calculations to use the standard parity_odd() helper.
> This change eliminates redundant implementations.
>
> Co-developed-by: Yu-Chun Lin <eleanor15x@...il.com>
> Signed-off-by: Yu-Chun Lin <eleanor15x@...il.com>
> Signed-off-by: Kuan-Wei Chiu <visitorckw@...il.com>
> ---
> drivers/media/pci/cx18/cx18-av-vbi.c | 12 ++----------
> 1 file changed, 2 insertions(+), 10 deletions(-)
>
> diff --git a/drivers/media/pci/cx18/cx18-av-vbi.c b/drivers/media/pci/cx18/cx18-av-vbi.c
> index 65281d40c681..15b515b95956 100644
> --- a/drivers/media/pci/cx18/cx18-av-vbi.c
> +++ b/drivers/media/pci/cx18/cx18-av-vbi.c
[...]
> @@ -278,7 +270,7 @@ int cx18_av_decode_vbi_line(struct v4l2_subdev *sd,
> break;
> case 6:
> sdid = V4L2_SLICED_CAPTION_525;
> - err = !odd_parity(p[0]) || !odd_parity(p[1]);
> + err = !parity_odd(p[0]) || !parity_odd(p[1]);
No need to call parity_odd() twice here. Instead you could do:
err = !parity_odd(p[0] ^ p[1]);
This is orthogonal to the change to parity_odd() though. More specific
to the new parity_odd() you can now do following as parity_odd()
argument is u64:
err = !parity_odd(*(u16 *)p);
Regards,
Arend
Powered by blists - more mailing lists