[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250416021549.606-1-tatyana.e.nikolova@intel.com>
Date: Tue, 15 Apr 2025 21:15:44 -0500
From: Tatyana Nikolova <tatyana.e.nikolova@...el.com>
To: jgg@...dia.com,
leon@...nel.org,
intel-wired-lan@...ts.osuosl.org
Cc: linux-rdma@...r.kernel.org,
netdev@...r.kernel.org
Subject: [iwl-next v5 0/5] Refactor to prepare for Intel IPU E2000 (GEN3)
To align with review comments, the patch series [v1] introducing RDMA
RoCEv2 support for the Intel Infrastructure Processing Unit (IPU) E2000
line of products is going to be submitted in three parts:
1. Modify ice to use specific and common IIDC definitions and
pass a core device info to irdma.
2. Add RDMA support to idpf and modify idpf to use specific and
common IIDC definitions and pass a core device info to irdma.
3. Add RDMA RoCEv2 support for the E2000 products, referred to as
GEN3 to irdma.
This first part is a 5 patch series based on the original
"iidc/ice/irdma: Update IDC to support multiple consumers" patch
to allow for multiple CORE PCI drivers, using the auxbus.
Patches:
1) Move header file to new name for clarity and replace ice
specific DSCP define with a kernel equivalent one in irdma
2) Unify naming convention
3) Separate header file into common and driver specific info
4) Replace ice specific DSCP define with a kernel equivalent
one in ice
5) Implement core device info struct and update drivers to use it
This patch series is based on v6.15-rc1.
Changelog:
V4 to V5 changes:
- Use exported symbols instead of a device ops struct
- Rename the IDC header file iidc.h to iidc_rdma.h
- Move ice specific functionality to iidc_rdma_ice.h
- Use iidc_* naming convention
- Replace ice specific DSCP define with a kernel equivalent one
V3 to V4 changes:
- Split up the patch series [v3] into three parts and
send out independently the ice/iidc related changes patch -
"iidc/ice/irdma: Update IDC to support multiple consumers"
[v4] https://lore.kernel.org/all/20250225050428.2166-1-tatyana.e.nikolova@intel.com/
[v3] https://lore.kernel.org/all/20250207194931.1569-1-tatyana.e.nikolova@intel.com/
[v2] https://lore.kernel.org/all/20240824031924.421-1-tatyana.e.nikolova@intel.com/
[v1] https://lore.kernel.org/all/20240724233917.704-1-tatyana.e.nikolova@intel.com/
Dave Ertman (4):
iidc/ice/irdma: Rename IDC header file
iidc/ice/irdma: Rename to iidc_* convention
iidc/ice/irdma: Break iidc.h into two headers
iidc/ice/irdma: Update IDC to support multiple consumers
Tatyana Nikolova (1):
ice: Replace ice specific DSCP mapping num with a kernel define
MAINTAINERS | 2 +-
drivers/infiniband/hw/irdma/main.c | 125 ++++++-----
drivers/infiniband/hw/irdma/main.h | 3 +-
drivers/infiniband/hw/irdma/osdep.h | 2 +-
drivers/infiniband/hw/irdma/type.h | 4 +-
.../net/ethernet/intel/ice/devlink/devlink.c | 45 +++-
drivers/net/ethernet/intel/ice/ice.h | 6 +-
drivers/net/ethernet/intel/ice/ice_dcb.c | 2 +-
drivers/net/ethernet/intel/ice/ice_dcb_lib.c | 47 +++-
drivers/net/ethernet/intel/ice/ice_dcb_lib.h | 9 +
drivers/net/ethernet/intel/ice/ice_dcb_nl.c | 4 +-
drivers/net/ethernet/intel/ice/ice_ethtool.c | 8 +-
drivers/net/ethernet/intel/ice/ice_idc.c | 204 +++++++++++-------
drivers/net/ethernet/intel/ice/ice_idc_int.h | 5 +-
drivers/net/ethernet/intel/ice/ice_main.c | 18 +-
drivers/net/ethernet/intel/ice/ice_type.h | 6 +-
include/linux/net/intel/iidc.h | 109 ----------
include/linux/net/intel/iidc_rdma.h | 68 ++++++
include/linux/net/intel/iidc_rdma_ice.h | 70 ++++++
19 files changed, 449 insertions(+), 288 deletions(-)
delete mode 100644 include/linux/net/intel/iidc.h
create mode 100644 include/linux/net/intel/iidc_rdma.h
create mode 100644 include/linux/net/intel/iidc_rdma_ice.h
--
2.37.3
Powered by blists - more mailing lists