[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <a12dee5c-2d59-4941-84b5-ae8bffcedd6c@amperemail.onmicrosoft.com>
Date: Mon, 28 Apr 2025 14:57:19 -0400
From: Adam Young <admiyo@...eremail.onmicrosoft.com>
To: Jonathan Cameron <Jonathan.Cameron@...wei.com>,
admiyo@...amperecomputing.com
Cc: Jeremy Kerr <jk@...econstruct.com.au>,
Matt Johnston <matt@...econstruct.com.au>,
Andrew Lunn <andrew+netdev@...n.ch>, "David S. Miller"
<davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org,
Sudeep Holla <sudeep.holla@....com>, Huisong Li <lihuisong@...wei.com>
Subject: Re: [PATCH net-next v20 1/1] mctp pcc: Implement MCTP over PCC
Transport
On 4/24/25 05:57, Jonathan Cameron wrote:
>> +
>> + mctp_pcc_header = skb_push(skb, sizeof(struct mctp_pcc_hdr));
> I'd use sizeof(*mctp_pcc_header) for these to avoid the reader needing to check
> types. There are a bunch of these you could do the same with to slightly
> improve readability.
I get a compilation error when I try that:
drivers/net/mctp/mctp-pcc.c: In function ‘mctp_pcc_client_rx_callback’:
drivers/net/mctp/mctp-pcc.c:80:30: error: invalid type argument of unary
‘*’ (have ‘struct mctp_pcc_hdr’)
80 | sizeof(*mctp_pcc_hdr));
Maybe a compiler flag difference?
Powered by blists - more mailing lists