lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 26 Mar 2013 20:08:28 -0700
From: Tony Arcieri <tony.arcieri@...il.com>
To: "discussions@...sword-hashing.net" <discussions@...sword-hashing.net>
Subject: Re: Suggestion: API should include a verifier function

On Tue, Mar 26, 2013 at 7:57 PM, Tony Arcieri <tony.arcieri@...il.com>wrote:

> you'd provide a user-supplied one as input, and verify via a guaranteed
> constant time comparison whether or not it's correct.
>

Oops, not quite what I meant to say there, but I'm sure you got the idea ;)

To clarify: you would pass in the hash/salt "on file" along with the
alleged password, and the function would return whether or not the provided
password matches the supplied hash/salt. The arguments are, otherwise, the
same as the hashing function.

As an API strawman, if this is our hashing function:

    PHS(out, outlen, in, inlen, salt, saltlen, t_cost, m_cost)

we might consider:

   PHS_VERIFY(hash, hashlen, in, inlen, salt, saltlen, t_cost, m_cost)

(I'm not particularly married to the name "PHS_VERIFY", so please bikeshed
away ;)

-- 
Tony Arcieri

Content of type "text/html" skipped

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ