lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 23 Jun 2016 10:38:27 -0300
From:	Arnaldo Carvalho de Melo <acme@...nel.org>
To:	Taeung Song <treeze.taeung@...il.com>
Cc:	linux-kernel@...r.kernel.org, Jiri Olsa <jolsa@...nel.org>,
	Namhyung Kim <namhyung@...nel.org>,
	Ingo Molnar <mingo@...nel.org>,
	Peter Zijlstra <peterz@...radead.org>,
	Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
	Masami Hiramatsu <mhiramat@...nel.org>,
	Wang Nan <wangnan0@...wei.com>, Jiri Olsa <jolsa@...hat.com>,
	Ingo Molnar <mingo@...hat.com>
Subject: Re: [PATCH v11 2/3] perf config: Reimplement perf_config()
 introducing new perf_config__init() and perf_config__finish()

Em Thu, Jun 23, 2016 at 10:03:39PM +0900, Taeung Song escreveu:
> +/**
> + * perf_config_sections__for_each - iterate thru all the sections
> + * @list: list_head instance to iterate
> + * @section: struct perf_config_section iterator
> + */
> +#define perf_config_sections__for_each(list, section)	\
> +        list_for_each_entry(section, list, node)
> +

I was almost applying this but then there is a little detail, which is
that it is a goal to make the tools/ code look as much as kernel code as
possible, to encourage kernel developers to contribute to the tools
codebase and also to expose userspace developers to kernel practices.

With that said, please rename these for_each macros to for_each_entry,
i.e.:

perf_config_sections__for_each_entry()
perf_config_items__for_each_entry()

As for_each and for_each_entry both exist in the kernel and have well
know semantics that we want to keep.

Probably there are cases in tools/ where we break this rule, I'll check
and fix.

Thanks,

- Arnaldo

> +/**
> + * perf_config_items__for_each - iterate thru all the items
> + * @list: list_head instance to iterate
> + * @item: struct perf_config_item iterator
> + */
> +#define perf_config_items__for_each(list, item)	\
> +        list_for_each_entry(item, list, node)
> +
> +/**
> + * perf_config_set__for_each - iterate thru all the config section-item pairs
> + * @set: evlist instance to iterate
> + * @section: struct perf_config_section iterator
> + * @item: struct perf_config_item iterator
> + */
> +#define perf_config_set__for_each(set, section, item)			\
> +	perf_config_sections__for_each(&set->sections, section)		\
> +	perf_config_items__for_each(&section->items, item)
>  
>  #endif /* __PERF_CONFIG_H */
> -- 
> 2.5.0

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ