lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 21 Mar 2018 18:50:54 -0500
From:   Alan Tull <atull@...nel.org>
To:     Wu Hao <hao.wu@...el.com>
Cc:     Moritz Fischer <mdf@...nel.org>, linux-fpga@...r.kernel.org,
        linux-kernel <linux-kernel@...r.kernel.org>,
        linux-api@...r.kernel.org, "Kang, Luwei" <luwei.kang@...el.com>,
        "Zhang, Yi Z" <yi.z.zhang@...el.com>,
        Xiao Guangrong <guangrong.xiao@...ux.intel.com>,
        Tim Whisonant <tim.whisonant@...el.com>,
        Enno Luebbers <enno.luebbers@...el.com>,
        Shiva Rao <shiva.rao@...el.com>,
        Christopher Rauer <christopher.rauer@...el.com>
Subject: Re: [PATCH v4 23/24] fpga: dfl: afu: add user afu sub feature support

On Tue, Mar 20, 2018 at 2:10 AM, Wu Hao <hao.wu@...el.com> wrote:

>> > +static int afu_mmap(struct file *filp, struct vm_area_struct *vma)
>> > +{
>> > +       struct fpga_afu_region region;
>> > +       struct platform_device *pdev = filp->private_data;
>> > +       struct feature_platform_data *pdata = dev_get_platdata(&pdev->dev);
>> > +       u64 size = vma->vm_end - vma->vm_start;
>> > +       u64 offset;
>> > +       int ret;
>> > +
>> > +       if (!(vma->vm_flags & VM_SHARED))
>> > +               return -EINVAL;
>> > +
>> > +       offset = vma->vm_pgoff << PAGE_SHIFT;
>> > +       ret = afu_get_region_by_offset(pdata, offset, size, &region);

Most of the functions here are afu_region_*, but there's also
afu_get_region_by_*.  Better if afu_region_get_by_* to be consistent.

>> > +       if (ret)
>> > +               return ret;
>> > +
>> > +       if (!(region.flags & FPGA_REGION_MMAP))
>>
>> FPGA_REGION_*?  We already have FPGA regions which are something
>> different.  Please call this something else.
>
> Yes, will replace it with DFL_FPGA_*.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ