lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
From: jaervosz at gentoo.org (Sune Kloppenborg Jeppesen)
Subject: [ GLSA 200411-38 ] Sun and Blackdown Java: Applet privilege escalation

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200411-38
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Sun and Blackdown Java: Applet privilege escalation
      Date: November 29, 2004
      Bugs: #72172, #72221
        ID: 200411-38

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The Java plug-in security in Sun and Blackdown Java environments can be
bypassed to access arbitrary packages, allowing untrusted Java applets
to perform unrestricted actions on the host system.

Background
==========

Sun and Blackdown both provide implementations of Java Development Kits
(JDK) and Java Runtime Environments (JRE). All these implementations
provide a Java plug-in that can be used to execute Java applets in a
restricted environment for web browsers.

Affected packages
=================

    -------------------------------------------------------------------
     Package                 /  Vulnerable  /               Unaffected
    -------------------------------------------------------------------
  1  dev-java/sun-jdk           < 1.4.2.06                 >= 1.4.2.06
  2  dev-java/sun-jre-bin       < 1.4.2.06                 >= 1.4.2.06
  3  dev-java/blackdown-jdk     < 1.4.2.01                 >= 1.4.2.01
  4  dev-java/blackdown-jre     < 1.4.2.01                 >= 1.4.2.01
    -------------------------------------------------------------------
     # Package 1 [dev-java/sun-jdk] only applies to x86 and AMD64
       users.
     # Package 2 [dev-java/sun-jre-bin] only applies to x86 and AMD64
       users.
     # Package 3 [dev-java/blackdown-jdk] only applies to x86 and
       AMD64 users.
     # Package 4 [dev-java/blackdown-jre] only applies to x86 and
       AMD64 users.
    -------------------------------------------------------------------
     4 affected packages; please see the notes above...
    -------------------------------------------------------------------

Description
===========

All Java plug-ins are subject to a vulnerability allowing unrestricted
Java package access.

Impact
======

A remote attacker could embed a malicious Java applet in a web page and
entice a victim to view it. This applet can then bypass security
restrictions and execute any command or access any file with the rights
of the user running the web browser.

Workaround
==========

As a workaround you could disable Java applets on your web browser.

Resolution
==========

All Sun JDK users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-java/sun-jdk-1.4.2.06"

All Sun JRE users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-java/sun-jre-bin-1.4.2.06"

All Blackdown JDK users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-java/blackdown-jdk-1.4.2.01"

All Blackdown JRE users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-java/blackdown-jre-1.4.2.01"

Note: You should unmerge all vulnerable versions to be fully protected.

References
==========

  [ 1 ] iDEFENSE Security Advisory 11.22.04
        http://www.idefense.com/application/poi/display?id=158&type=vulnerabilities
  [ 2 ] CAN-2004-1029
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1029
  [ 3 ] Blackdown Security Advisory 2004-01
        http://www.blackdown.org/java-linux/java2-status/security/Blackdown-SA-2004-01.txt

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200411-38.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@...too.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.grok.org.uk/pipermail/full-disclosure/attachments/20041129/6d49b6e9/attachment.bin

Powered by blists - more mailing lists