lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 5 Oct 2012 00:28:16 -0400
From:	Theodore Ts'o <tytso@....edu>
To:	Anatol Pomozov <anatol.pomozov@...il.com>
Cc:	Dmitry Monakhov <dmonakhov@...nvz.org>, linux-ext4@...r.kernel.org,
	jack@...e.cz, lczerner@...hat.com
Subject: Re: [PATCH 05/11] ext4: remove ext4_end_io()

I ended up dropping this patch since it doesn't make any difference to
the generated code (gcc will take a static function which is only used
in one place, and inline it) and it makes a bit more understandable to
have ext4_end_io() as a separate function.

> > +               /* Wake up anyone waiting on unwritten extent conversion */
> > +               if (atomic_dec_and_test(&EXT4_I(inode)->i_unwritten))
> > +                       wake_up_all(ext4_ioend_wq(io->inode));
> 
> Should we use "inode" instead of "io->inode"?

I agree it would be a bit cleaner/more readable, but again it won't
make a difference to the generated assembly, and while we oculd do
this in the original code in ext4_end_io(), I'm trying to put this
patch series to bed so I can push it to Linus, and since we're now not
touching the code, it's not worth it to clean this up now.  We can
take of this later....

						- Ted
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists