lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 31 Jan 2018 12:55:24 -0500
From:   Jeff Layton <>
To:     Linus Torvalds <>
Cc:     linux-fsdevel <>,
        Linux Kernel Mailing List <>,
        Al Viro <>,
        Linux NFS Mailing List <>,, Theodore Ts'o <>,
        linux-xfs <>,
        linux-btrfs <>,
        linux-integrity <>,
        Trond Myklebust <>,
        GoffredoBaroncelli <>
Subject: Re: [PATCH v2] iversion: make inode_cmp_iversion{+raw} return bool
 instead of s64

On Wed, 2018-01-31 at 08:46 -0800, Linus Torvalds wrote:
> On Wed, Jan 31, 2018 at 4:29 AM, Jeff Layton <> wrote:
> > 
> > Do you mind just taking it directly? I don't have anything else queued
> > up for this cycle.
> Done.

Thanks...and also many thanks for spotting the original issue. I agree
that this makes it much harder for the callers to get things wrong (and
is probably much more efficient on some arches, as Ted pointed out).

> I wonder if "false for same, true for different" calling convention
> makes much sense, but it matches the old "0 for same" so obviously
> makes for a smaller diff.
> If it ever ends up confusing people, maybe the sense of that function
> should be reversed, and the name changed to something like
> "same_inode_version()" or something.
> But at least for now the situation seems ok to me,

G. Baroncelli suggested changing the name too, so maybe we should just
go ahead and do it. Let me think on what the best approach is and I may
try to send another patch or PR before the end of the merge window.

Jeff Layton <>

Powered by blists - more mailing lists