lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 16 Nov 2020 11:21:54 +0000
From:   Luca Boccassi <luca.boccassi@...il.com>
To:     Eric Biggers <ebiggers@...nel.org>, linux-fscrypt@...r.kernel.org
Cc:     linux-ext4@...r.kernel.org, linux-f2fs-devel@...ts.sourceforge.net,
        Victor Hsieh <victorhsieh@...gle.com>,
        Jes Sorensen <Jes.Sorensen@...il.com>,
        Martijn Coenen <maco@...roid.com>,
        Paul Lawrence <paullawrence@...gle.com>
Subject: Re: [PATCH 3/4] fs-verity: rename "file measurement" to "file
 digest"

On Fri, 2020-11-13 at 13:19 -0800, Eric Biggers wrote:
> From: Eric Biggers <ebiggers@...gle.com>
> 
> I originally chose the name "file measurement" to refer to the fs-verity
> file digest to avoid confusion with traditional full-file digests or
> with the bare root hash of the Merkle tree.
> 
> But the name "file measurement" hasn't caught on, and usually people are
> calling it something else, usually the "file digest".  E.g. see
> "struct fsverity_digest" and "struct fsverity_formatted_digest", the
> libfsverity_compute_digest() and libfsverity_sign_digest() functions in
> libfsverity, and the "fsverity digest" command.
> 
> Having multiple names for the same thing is always confusing.
> 
> So to hopefully avoid confusion in the future, rename
> "fs-verity file measurement" to "fs-verity file digest".
> 
> This leaves FS_IOC_MEASURE_VERITY as the only reference to "measure" in
> the kernel, which makes some amount of sense since the ioctl is actively
> "measuring" the file.
> 
> I'll be renaming this in fsverity-utils too (though similarly the
> 'fsverity measure' command, which is a wrapper for
> FS_IOC_MEASURE_VERITY, will stay).
> 
> Signed-off-by: Eric Biggers <ebiggers@...gle.com>
> ---
>  Documentation/filesystems/fsverity.rst | 60 +++++++++++++-------------
>  fs/verity/enable.c                     |  6 +--
>  fs/verity/fsverity_private.h           | 12 +++---
>  fs/verity/measure.c                    | 12 +++---
>  fs/verity/open.c                       | 22 +++++-----
>  fs/verity/signature.c                  | 10 ++---
>  6 files changed, 61 insertions(+), 61 deletions(-)

Acked-by: Luca Boccassi <luca.boccassi@...rosoft.com>

-- 
Kind regards,
Luca Boccassi

Download attachment "signature.asc" of type "application/pgp-signature" (489 bytes)

Powered by blists - more mailing lists