lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 23 Dec 2022 23:23:34 -0800
From:   Christoph Hellwig <>
To:     Andreas Gr├╝nbacher 
Cc:     Christoph Hellwig <>,
        Andreas Gruenbacher <>,
        "Darrick J . Wong" <>,
        Alexander Viro <>,
        Matthew Wilcox <>,,,,
Subject: Re: [RFC v3 4/7] iomap: Add iomap_folio_prepare helper

On Fri, Dec 23, 2022 at 10:05:05PM +0100, Andreas Gr├╝nbacher wrote:
> > I'd name this __iomap_get_folio to match __filemap_get_folio.
> I was looking at it from the filesystem point of view: this helper is
> meant to be used in ->folio_prepare() handlers, so
> iomap_folio_prepare() seemed to be a better name than
> __iomap_get_folio().

Well, I think the right name for the methods that gets a folio is
probably ->folio_get anyway.

Powered by blists - more mailing lists