[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZEZ2gCYFlurJfeDE@casper.infradead.org>
Date: Mon, 24 Apr 2023 13:30:56 +0100
From: Matthew Wilcox <willy@...radead.org>
To: Christoph Hellwig <hch@....de>
Cc: Jens Axboe <axboe@...nel.dk>, Miklos Szeredi <miklos@...redi.hu>,
"Darrick J. Wong" <djwong@...nel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
David Howells <dhowells@...hat.com>,
linux-block@...r.kernel.org, linux-fsdevel@...r.kernel.org,
ceph-devel@...r.kernel.org, linux-ext4@...r.kernel.org,
linux-f2fs-devel@...ts.sourceforge.net, cluster-devel@...hat.com,
linux-xfs@...r.kernel.org, linux-nfs@...r.kernel.org,
linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 03/17] fs: rename and move block_page_mkwrite_return
On Mon, Apr 24, 2023 at 07:49:12AM +0200, Christoph Hellwig wrote:
> block_page_mkwrite_return is neither block nor mkwrite specific, and
> should not be under CONFIG_BLOCK. Move it to mm.h and rename it to
> errno_to_vmfault.
Could you move it about 300 lines down and put it near vmf_error()
so we think about how to unify the two at some point?
Perhaps it should better be called vmf_fs_error() for now since the
errnos it handles are the kind generated by filesystems.
> +++ b/include/linux/mm.h
> @@ -3061,6 +3061,19 @@ extern vm_fault_t filemap_map_pages(struct vm_fault *vmf,
> pgoff_t start_pgoff, pgoff_t end_pgoff);
> extern vm_fault_t filemap_page_mkwrite(struct vm_fault *vmf);
>
> +/* Convert errno to return value from ->page_mkwrite() call */
> +static inline vm_fault_t errno_to_vmfault(int err)
> +{
> + if (err == 0)
> + return VM_FAULT_LOCKED;
> + if (err == -EFAULT || err == -EAGAIN)
> + return VM_FAULT_NOPAGE;
> + if (err == -ENOMEM)
> + return VM_FAULT_OOM;
> + /* -ENOSPC, -EDQUOT, -EIO ... */
> + return VM_FAULT_SIGBUS;
> +}
> +
> extern unsigned long stack_guard_gap;
Powered by blists - more mailing lists