lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 24 Apr 2023 14:42:34 +0200
From:   Christoph Hellwig <>
To:     Matthew Wilcox <>
Cc:     Christoph Hellwig <>, Jens Axboe <>,
        Miklos Szeredi <>,
        "Darrick J. Wong" <>,
        Andrew Morton <>,
        David Howells <>,,,,,,,,,,
Subject: Re: [PATCH 03/17] fs: rename and move block_page_mkwrite_return

On Mon, Apr 24, 2023 at 01:30:56PM +0100, Matthew Wilcox wrote:
> On Mon, Apr 24, 2023 at 07:49:12AM +0200, Christoph Hellwig wrote:
> > block_page_mkwrite_return is neither block nor mkwrite specific, and
> > should not be under CONFIG_BLOCK.  Move it to mm.h and rename it to
> > errno_to_vmfault.
> Could you move it about 300 lines down and put it near vmf_error()
> so we think about how to unify the two at some point?
> Perhaps it should better be called vmf_fs_error() for now since the
> errnos it handles are the kind generated by filesystems.

I'll look into unifying them for the next version.

Powered by blists - more mailing lists