lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening linux-cve-announce PHC | |
Open Source and information security mailing list archives
| ||
|
Message-ID: <ee3f75c1555c927e05b78c1afca1ed5a3b2cd50f.camel@perches.com> Date: Thu, 01 Oct 2020 08:39:39 -0700 From: Joe Perches <joe@...ches.com> To: "Gustavo A. R. Silva" <gustavoars@...nel.org>, Steve Wahl <steve.wahl@....com>, Dimitri Sivanich <dimitri.sivanich@....com>, Russ Anderson <russ.anderson@....com>, Darren Hart <dvhart@...radead.org>, Andy Shevchenko <andy@...radead.org>, Thomas Gleixner <tglx@...utronix.de>, Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>, "H. Peter Anvin" <hpa@...or.com> Cc: x86@...nel.org, platform-driver-x86@...r.kernel.org, linux-kernel@...r.kernel.org, Kees Cook <keescook@...omium.org>, linux-hardening@...r.kernel.org Subject: Re: [PATCH v2][next] x86/uv/time: Replace one-element array and save heap space On Thu, 2020-10-01 at 09:56 -0500, Gustavo A. R. Silva wrote: > There is a regular need in the kernel to provide a way to declare having > a dynamically sized set of trailing elements in a structure. Kernel code > should always use “flexible array members”[1] for these cases. The older > style of one-element or zero-length arrays should no longer be used[2]. > > struct uv_rtc_timer_head contains a one-element array cpu[1]. > > Switch it to a flexible array and use the struct_size() helper to > calculate the allocation size. Also, save some heap space in the > process[3]. trivia: > diff --git a/arch/x86/platform/uv/uv_time.c b/arch/x86/platform/uv/uv_time.c [] > @@ -148,9 +148,8 @@ static __init int uv_rtc_allocate_timers(void) > struct uv_rtc_timer_head *head = blade_info[bid]; > > if (!head) { > - head = kmalloc_node(sizeof(struct uv_rtc_timer_head) + > - (uv_blade_nr_possible_cpus(bid) * > - 2 * sizeof(u64)), > + head = kmalloc_node(struct_size(head, cpu, > + uv_blade_nr_possible_cpus(bid)), > GFP_KERNEL, nid); > if (!head) { > uv_rtc_deallocate_timers(); Maybe save the value of uv_blade_nr_possible_cpus(bid) to reduce duplication and make the sizeof_struct more readable? if (!head) { int ncpus = uv_blade_nr_possible_cpus(bid); head = kmalloc_node(struct_size(head, cpu, ncpus), GFP_KERNEL, nid); if (!head) { uv_rtc_deallocate_timers(); return -ENOMEM; } spin_lock_init(&head->lock); head->ncpus = ncpus; head->next_cpu = -1; blade_info[bid] = head; }
Powered by blists - more mailing lists