[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <202402121031.4649560C1@keescook>
Date: Mon, 12 Feb 2024 10:31:11 -0800
From: Kees Cook <keescook@...omium.org>
To: Erick Archer <erick.archer@....com>
Cc: David Woodhouse <dwmw2@...radead.org>,
Lu Baolu <baolu.lu@...ux.intel.com>, Joerg Roedel <joro@...tes.org>,
Will Deacon <will@...nel.org>, Robin Murphy <robin.murphy@....com>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
iommu@...ts.linux.dev, linux-kernel@...r.kernel.org,
linux-hardening@...r.kernel.org
Subject: Re: [PATCH] iommu/vt-d: Use kcalloc() instead of kzalloc()
On Sun, Feb 11, 2024 at 06:51:43PM +0100, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> Here the multiplication is obviously safe because DMAR_LATENCY_NUM
> is the number of latency types defined in the "latency_type" enum.
>
> enum latency_type {
> DMAR_LATENCY_INV_IOTLB = 0,
> DMAR_LATENCY_INV_DEVTLB,
> DMAR_LATENCY_INV_IEC,
> DMAR_LATENCY_PRQ,
> DMAR_LATENCY_NUM
> };
>
> However, using kcalloc() is more appropriate [2] and improves
> readability. This patch has no effect on runtime behavior.
>
> Link: https://github.com/KSPP/linux/issues/162 [1]
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [2]
> Signed-off-by: Erick Archer <erick.archer@....com>
Looks reasonable.
Reviewed-by: Kees Cook <keescook@...omium.org>
--
Kees Cook
Powered by blists - more mailing lists