[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b66caca8-a8d8-4081-b462-92a95a7fa830@embeddedor.com>
Date: Mon, 12 Feb 2024 14:41:38 -0600
From: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
To: Erick Archer <erick.archer@....com>, David Woodhouse
<dwmw2@...radead.org>, Lu Baolu <baolu.lu@...ux.intel.com>,
Joerg Roedel <joro@...tes.org>, Will Deacon <will@...nel.org>,
Robin Murphy <robin.murphy@....com>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
Kees Cook <keescook@...omium.org>
Cc: iommu@...ts.linux.dev, linux-kernel@...r.kernel.org,
linux-hardening@...r.kernel.org
Subject: Re: [PATCH] iommu/vt-d: Use kcalloc() instead of kzalloc()
On 2/11/24 11:51, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> Here the multiplication is obviously safe because DMAR_LATENCY_NUM
> is the number of latency types defined in the "latency_type" enum.
>
> enum latency_type {
> DMAR_LATENCY_INV_IOTLB = 0,
> DMAR_LATENCY_INV_DEVTLB,
> DMAR_LATENCY_INV_IEC,
> DMAR_LATENCY_PRQ,
> DMAR_LATENCY_NUM
> };
>
> However, using kcalloc() is more appropriate [2] and improves
> readability. This patch has no effect on runtime behavior.
>
> Link: https://github.com/KSPP/linux/issues/162 [1]
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [2]
> Signed-off-by: Erick Archer <erick.archer@....com>
LGTM:
Reviewed-by: Gustavo A. R. Silva <gustavoars@...nel.org>
Thanks!
--
Gustavo
> ---
> drivers/iommu/intel/perf.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/iommu/intel/perf.c b/drivers/iommu/intel/perf.c
> index 94ee70ac38e3..adc4de6bbd88 100644
> --- a/drivers/iommu/intel/perf.c
> +++ b/drivers/iommu/intel/perf.c
> @@ -33,7 +33,7 @@ int dmar_latency_enable(struct intel_iommu *iommu, enum latency_type type)
>
> spin_lock_irqsave(&latency_lock, flags);
> if (!iommu->perf_statistic) {
> - iommu->perf_statistic = kzalloc(sizeof(*lstat) * DMAR_LATENCY_NUM,
> + iommu->perf_statistic = kcalloc(DMAR_LATENCY_NUM, sizeof(*lstat),
> GFP_ATOMIC);
> if (!iommu->perf_statistic) {
> ret = -ENOMEM;
> --
> 2.25.1
>
>
Powered by blists - more mailing lists