lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 21 Jul 2006 13:14:10 +0300 (EEST)
From:	Pekka J Enberg <penberg@...Helsinki.FI>
To:	Panagiotis Issaris <>
cc:	Jeff Garzik <>,
	Rolf Eike Beer <>,
	Panagiotis Issaris <>,,,,,,,,,,,,,,,,,
Subject: Re: [PATCH] drivers: Conversions from kmalloc+memset tok(z|c)alloc.

On Fri, 21 Jul 2006, Panagiotis Issaris wrote:
> Ah okay. Up until now, I thought it would be okay to change the style of
> the code if it was listed in the CodingStyle document and in any other
> cause should be left untouched as it would be left to the maintainers
> personal preference. That's why I explicitly asked about the "if ((buf =
> kmalloc(...)==NULL) -> buf = kmalloc(...); if (!buf)" type of changes.
> Ofcourse, I should have put cosmetic changes in a separate patch anyway.

At least Andrew seems to prefer cleaning up in the same patch. Anyway, I 
don't think Jeff meant that you shouldn't do any cleanups, but that you 
should try to respect the existing style as much possible. There are 
things that are almost generally agreed upon, such as removal of redundant 
typecasts, redundant wrappers, and moving assignment out of if statement 
expression. Formatting and the dreaded sizeof thing, however, 
are not, so it is best to keep them as-is.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists