[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <000501c6ef07$79c1c770$ff0da8c0@amr.corp.intel.com>
Date: Fri, 13 Oct 2006 13:38:01 -0700
From: "Chen, Kenneth W" <kenneth.w.chen@...el.com>
To: "'Benjamin LaHaise'" <bcrl@...ck.org>
Cc: "'Zach Brown'" <zach.brown@...cle.com>,
"'Suparna Bhattacharya'" <suparna@...ibm.com>,
"Lahaise, Benjamin C" <benjamin.c.lahaise@...el.com>,
<linux-kernel@...r.kernel.org>, "'linux-aio'" <linux-aio@...ck.org>
Subject: RE: [patch] clarify AIO_EVENTS_OFFSET constant
Benjamin LaHaise wrote on Friday, October 13, 2006 7:23 AM
> On Thu, Oct 12, 2006 at 05:00:24PM -0700, Chen, Kenneth W wrote:
> > A clean up patch: I think it is a lot easier to read AIO_EVENTS_OFFSET
> > as an offset because of aio_ring at the beginning of a head page, instead
> > of doing arithmetic of (event on 2nd page - event on 1st page).
>
> Nak. Your change fails if aio_ring is not an exact multiple of the
> io_event size due to rounding errors, while the original code rounds
> correctly.
Yeah, neither form is bullet proof, even the original one will break down
when io_event size is not in power of 2. The good news is that no where
near in sight that these two data structures size will change.
To make it a real bullet proof, it should be something like the following:
#define AIO_EVENTS_OFFSET ((sizeof(struct aio_ring) + \
sizeof(struct io_event) - 1 ) / \
sizeof(struct io_event))
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists