lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 27 Jan 2007 00:24:53 -0800
From:	Andrew Morton <akpm@...l.org>
To:	Alon Bar-Lev <alon.barlev@...il.com>
Cc:	linux-arch@...r.kernel.org, linux-kernel@...r.kernel.org,
	"H. Peter Anvin" <hpa@...or.com>, Bernhard Walle <bwalle@...e.de>
Subject: Re: [PATCH 10/26] Dynamic kernel command-line - ia64

On Tue, 23 Jan 2007 00:14:06 +0200
Alon Bar-Lev <alon.barlev@...il.com> wrote:

> 
> 1. Rename saved_command_line into boot_command_line.
> 2. Set command_line as __initdata.
> 
> Signed-off-by: Alon Bar-Lev <alon.barlev@...il.com>
> 
> ---
> 
> diff -urNp linux-2.6.20-rc4-mm1.org/arch/ia64/kernel/efi.c linux-2.6.20-rc4-mm1/arch/ia64/kernel/efi.c
> --- linux-2.6.20-rc4-mm1.org/arch/ia64/kernel/efi.c	2007-01-07 07:45:51.000000000 +0200
> +++ linux-2.6.20-rc4-mm1/arch/ia64/kernel/efi.c	2007-01-22 23:32:30.000000000 +0200
> @@ -413,11 +413,11 @@ efi_init (void)
>  	efi_char16_t *c16;
>  	u64 efi_desc_size;
>  	char *cp, vendor[100] = "unknown";
> -	extern char saved_command_line[];
> +	extern char __initdata boot_command_line[];
>  	int i;
>  
>  chk_nointroute_opt(void)
>  {
>  	char *cp;
> -	extern char saved_command_line[];
> +	extern char __initdata boot_command_line[];

no no no no no no no.  Just because some whacked-out weenie went and put
extern declarations in .c files doesn't mean that we should copy them.

It doesn't even compile.

arch/ia64/kernel/efi.c: In function `efi_init':
arch/ia64/kernel/efi.c:416: error: section attribute cannot be specified for local variables

Please.  Go through the entire patchset, yank all those wrong private
declarations of boot_command_line[] and put a *single, kernel-wide*
declaration into a single, shared header file.

Thanks.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ