[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20070203215848.GA10440@Ahmed>
Date: Sat, 3 Feb 2007 23:58:48 +0200
From: "Ahmed S. Darwish" <darwish.07@...il.com>
To: linux-kernel@...r.kernel.org
Subject: A CodingStyle suggestion
Hi all,
In CodingStyle Chapter 16 "Function return value and names", why not
adding a comment about the favorable community way of checking the return
value. ie:
ret = do_method();
if (ret) {
/* deal with error */
}
and not other ways like:
if (do_method()) or if ((ret = do_method()) > value) ...
A patch is ready if the replies are positive.
Thanks,
--
Ahmed S. Darwish
http://darwish-07.blogspot.com
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists