[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <45C51310.6070304@student.ltu.se>
Date: Sat, 03 Feb 2007 23:56:16 +0100
From: Richard Knutsson <ricknu-0@...dent.ltu.se>
To: "Ahmed S. Darwish" <darwish.07@...il.com>
CC: linux-kernel@...r.kernel.org
Subject: Re: A CodingStyle suggestion
Ahmed S. Darwish wrote:
> Hi all,
>
> In CodingStyle Chapter 16 "Function return value and names", why not
> adding a comment about the favorable community way of checking the return
> value. ie:
>
> ret = do_method();
> if (ret) {
> /* deal with error */
> }
>
> and not other ways like:
>
> if (do_method()) or
So:
if (is_true()) {
/* do something */
}
is alright then? If so, I agree, but please make it real clear in the
document ;)
Richard Knutsson
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists