[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20070213.164857.33144817.yoshfuji@linux-ipv6.org>
Date: Tue, 13 Feb 2007 16:48:57 +0900 (JST)
From: YOSHIFUJI Hideaki / 吉藤英明
<yoshfuji@...ux-ipv6.org>
To: joe@...ches.com
Cc: linux-kernel@...r.kernel.org, yoshfuji@...ux-ipv6.org
Subject: Re: Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)"
to "array_for_each(index, array)"
In article <1171324070.1528.25.camel@...alhost> (at Mon, 12 Feb 2007 15:47:50 -0800), Joe Perches <joe@...ches.com> says:
> Now that most of the sizeof(array)/sizeof(array[0])
> conversions have been done (there are about 800 done
> and about another 130 left), perhaps it could be
> useful to change the code to use a define similar
> to the list_for_each
>
> #define list_for_each(pos, head) \
> for (pos = (head)->next; prefetch(pos->next), pos != (head); \
> pos = pos->next)
>
> perhaps
>
> #define array_for_each(index, array) \
> for ((index) = 0; (index) < ARRAY_SIZE((array)); (index)++)
I dislike this; it is overkill.
list_for_each etc. are for list_head etc., of structures.
On the other hand, arrays are not.
It is very, very obvious how to access its members.
--yoshfuji
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists