[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8bd0f97a0705211049i25867b27kf0017602ad4a0537@mail.gmail.com>
Date: Mon, 21 May 2007 12:49:29 -0500
From: "Mike Frysinger" <vapier.adi@...il.com>
To: "Pekka Enberg" <penberg@...helsinki.fi>
Cc: "Bryan Wu" <bryan.wu@...log.com>, torvalds@...ux-foundation.org,
akpm@...ux-foundation.org, linux-kernel@...r.kernel.org,
"Aubrey Li" <aubrey.li@...log.com>
Subject: Re: [PATCH 20/32] Blackfin arch: dma_memcpy borken for > 64K
On 5/21/07, Pekka Enberg <penberg@...helsinki.fi> wrote:
> On 5/21/07, Bryan Wu <bryan.wu@...log.com> wrote:
> > -void *dma_memcpy(void *dest, const void *src, size_t size)
> > +void *_dma_memcpy(void *dest, const void *src, size_t size)
>
> Minor nitpick: the established naming convention is two underscores, not one.
that should be marked as static now actually since the function isnt
for use outside of this file
> > +void *dma_memcpy(void *dest, const void *src, size_t size)
> > +{
> > + size_t bulk;
> > + size_t rest;
> > + void * addr;
> > +
> > + bulk = (size >> 16) << 16;
>
> I assume this is significantly faster on your architecture than:
>
> bulk = size & ~0xFFFFUL;
>
> which is more readable?
actually they should get optimized to the same thing
-mike
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists