[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <p736469dsdb.fsf@bingen.suse.de>
Date: 31 May 2007 15:39:44 +0200
From: Andi Kleen <andi@...stfloor.org>
To: Mathieu Desnoyers <mathieu.desnoyers@...ymtl.ca>
Cc: akpm@...ux-foundation.org, linux-kernel@...r.kernel.org
Subject: Re: [patch 9/9] Scheduler profiling - Use conditional calls
Mathieu Desnoyers <mathieu.desnoyers@...ymtl.ca> writes:
> }
> - profile_hit(SCHED_PROFILING, __builtin_return_address(0));
> + cond_call(profile_on,
> + profile_hit(SCHED_PROFILING, __builtin_return_address(0)));
Would it be possible to use a syntax like
if (unlikely_cond_call(variable)) { (or better name)
...
}
instead? I think that would be much nicer to read than having
code in a macro argument
-Andi
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists