lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <46AFDC9A.1050901@s5r6.in-berlin.de>
Date:	Wed, 01 Aug 2007 03:06:34 +0200
From:	Stefan Richter <stefanr@...6.in-berlin.de>
To:	jack@...keye.stone.uk.eu.org
CC:	linux-kernel@...r.kernel.org, trivial@...nel.org,
	Mikael Starvik <starvik@...s.com>
Subject: Re: [Patch 01/16] Remove unnecessary kmalloc casts from the cris
 arch.

jack@...keye.stone.uk.eu.org wrote:
> --- a/arch/cris/arch-v32/mm/intmem.c
> +++ b/arch/cris/arch-v32/mm/intmem.c
> @@ -28,7 +28,7 @@ static void crisv32_intmem_init(void)
>  	static int initiated = 0;
>  	if (!initiated) {
>  		struct intmem_allocation* alloc =
> -		  (struct intmem_allocation*)kmalloc(sizeof *alloc, GFP_KERNEL);
> +				kmalloc(sizeof *alloc, GFP_KERNEL);
>  		INIT_LIST_HEAD(&intmem_allocations);
>  		intmem_virtual = ioremap(MEM_INTMEM_START, MEM_INTMEM_SIZE);
>  		initiated = 1;
> 

Would be nice if you increased the indentation of the kmalloc line for
better readability, now that the expression is shorter.

In the rest of arch/cris/arch-v32/mm/intmem.c, one tab is typically used
for such continuation indentations.  However, intmem.c is not a prime
example for good whitespace usage, so you could as well use two tabs.

Also note that there are two more kmallocs with unnecessary cast in the
same file, at least in 2.6.23-rc1.  Would be nice if you cleaned up the
whole file at once.

There is also a shadowing of a local variable (tmp) by another local
variable of the same name.  Maybe you could submit another cleanup patch
for that too while you are at it?
-- 
Stefan Richter
-=====-=-=== =--- ----=
http://arcgraph.de/sr/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ