lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 22 Aug 2007 18:17:50 +0200
From:	"Rafael J. Wysocki" <rjw@...k.pl>
To:	Pavel Machek <pavel@....cz>
Cc:	Andi Kleen <ak@...e.de>, LKML <linux-kernel@...r.kernel.org>,
	pm list <linux-pm@...ts.linux-foundation.org>
Subject: Re: [RFC][PATCH -mm 3/4] Hibernation: Pass CR3 in the image header on x86_64

On Wednesday, 22 August 2007 10:28, Pavel Machek wrote:
> Hi!
> 
> > From: Rafael J. Wysocki <rjw@...k.pl>
> > 
> > Since we already pass the address of restore_registers() in the image header,
> > we can also pass the value of the CR3 register from before the hibernation in
> > the same way.  This will allow us to avoid using init_level4_pgt page tables
> > during the restore.
> > 
> > Signed-off-by: Rafael J. Wysocki <rjw@...k.pl>
> 
> > @@ -253,10 +262,13 @@ int arch_hibernation_header_save(void *a
> >  {
> >  	struct restore_data_record *rdr = addr;
> >  
> > -	if (max_size < sizeof(struct restore_data_record))
> > +	if (max_size < sizeof(*rdr))
> >  		return -EOVERFLOW;
> >  	rdr->jump_address = restore_jump_address;
> > -	rdr->control = (restore_jump_address ^ RESTORE_MAGIC);
> > +	rdr->cr3 = restore_cr3;
> > +	rdr->magic = RESTORE_MAGIC;
> > +	rdr->crc = 0;
> > +	rdr->crc = crc32_le(0, addr, sizeof(*rdr));
> >  	return 0;
> >  }
> 
> No, I do not think I like that. I believe both -> control and -> crc
> is just useless paranoia. Bitflip in this area is not going to be any
> worse than bitflip anywhere else, we should not pretend this is
> somehow "more important".
> 
> -> control should really be "protocol version"... probably should
> contain some field that is easy to increment.

OK

Perhaps I'll just remove the crc field.  What do you think?

Rafael
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ