lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 17 Sep 2007 20:33:46 +0200
From:	Borislav Petkov <bbpetkov@...oo.de>
To:	Jeremy Fitzhardinge <jeremy@...p.org>
Cc:	linux-kernel@...r.kernel.org
Subject: Re: [PATCH 0/2] unify DMA_..BIT_MASK definitions

On Mon, Sep 17, 2007 at 11:14:48AM -0700, Jeremy Fitzhardinge wrote:
> Borislav Petkov wrote:
> > This patches remove redundant DMA_..BIT_MASK definitions across two drivers.
> > First off, consolidate dma bitmask definitions in the proper header file...
> >
> > Signed-off-by: Borislav Petkov <bbpetkov@...oo.de>
> >
> > --
> > Index: 23-rc6/include/linux/dma-mapping.h
> > ===================================================================
> > --- 23-rc6/include/linux/dma-mapping.h.orig	2007-09-17 17:48:20.000000000 +0200
> > +++ 23-rc6/include/linux/dma-mapping.h	2007-09-17 19:34:21.000000000 +0200
> > @@ -17,6 +17,7 @@
> >  #define DMA_48BIT_MASK	0x0000ffffffffffffULL
> >  #define DMA_40BIT_MASK	0x000000ffffffffffULL
> >  #define DMA_39BIT_MASK	0x0000007fffffffffULL
> > +#define DMA_35BIT_MASK	0x00000007ffffffffULL
> >  #define DMA_32BIT_MASK	0x00000000ffffffffULL
> >  #define DMA_31BIT_MASK	0x000000007fffffffULL
> >  #define DMA_30BIT_MASK	0x000000003fffffffULL
> >   
> 
> Hm.  Wouldn't it be better to define something like
> 
> #define DMA_BIT_MASK(x)    ((1ull<<(x))-1)
> 
> and then define everything in terms of that (or just use it directly and
> deprecate the DMA_XXBIT_MASK macros)?
> 
>     J
That is more compact, I agree. However, the XXBIT_MASK macros have the
better readability, imho. And also, doing 

$grep -Prin 'DMA_..BIT_MASK' * | wc -l

returns 383 on the 23-rc6 tree so removing them should be quite the logistical
challenge for the kernel janitors :). What do the others think?

-- 
Regards/Gruß,
    Boris.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ