[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1191330132.11136.2.camel@norville.austin.ibm.com>
Date: Tue, 02 Oct 2007 13:02:12 +0000
From: Dave Kleikamp <shaggy@...ux.vnet.ibm.com>
To: David Howells <dhowells@...hat.com>
Cc: Zach Brown <zab@...bo.net>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Christoph Hellwig <hch@...radead.org>, viro@....linux.org.uk,
akpm@...ux-foundation.org, linux-kernel@...r.kernel.org,
linux-fsdevel@...r.kernel.org
Subject: Re: [PATCH 07/30] IGET: Stop BEFS from using iget() and
read_inode()
On Tue, 2007-10-02 at 13:32 +0100, David Howells wrote:
> Zach Brown <zab@...bo.net> wrote:
>
> > /* haha, continuing the fine tradition of terrible names in this api.. */
> > static inline void *PTR_PTR(void *err_ptr) {
> > BUG_ON(!IS_ERR(err_ptr) || !err_ptr);
> > return err_ptr;
> > }
>
> How about ERR_CAST() instead? Or maybe CAST_ERR()?
It's a better name than PTR_PTR(). :-)
>
> struct dentry *blah(...)
> {
> struct inode *inode;
>
> inode = thing(...);
> if (IS_ERR(inode))
> return ERR_CAST(inode);
> }
>
> Where ERR_CAST is defined as:
>
> static inline void *ERR_CAST(const void *error)
> {
> return (void *) x;
> }
Of course, the cast is unnecessary, and I'm sure you meant to return
error:
static inline void *ERR_CAST(const void *error)
{
return error;
}
Shaggy
--
David Kleikamp
IBM Linux Technology Center
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists