[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1192456662.27435.74.camel@twins>
Date: Mon, 15 Oct 2007 15:57:42 +0200
From: Peter Zijlstra <a.p.zijlstra@...llo.nl>
To: Dmitry Adamushko <dmitry.adamushko@...il.com>
Cc: linux-kernel <linux-kernel@...r.kernel.org>,
Ingo Molnar <mingo@...e.hu>,
Thomas Gleixner <tglx@...utronix.de>,
Mike Galbraith <efault@....de>,
Lennart Poettering <mztabzr@...inter.de>
Subject: Re: [RFC][PATCH] sched: SCHED_FIFO watchdog timer
On Mon, 2007-10-15 at 15:26 +0200, Dmitry Adamushko wrote:
> On 14/10/2007, Peter Zijlstra <a.p.zijlstra@...llo.nl> wrote:
> > The below patch is an idea proposed by tglx and depends on sched-devel +
> > the hrtick patch previously posted.
> >
> > The current watchdog action is to demote the task to SCHED_NORMAL,
> > however it might be wanted to deliver a signal instead (or have more per
> > task configuration state). Which is why I added Lennart to the CC list
> > as I gathered he would like something like this for PulseAudio.
> >
> > ---
> > Subject: sched: SCHED_FIFO watchdog timer
>
> Why only SHCED_FIFO and not SCHED_RR?
> Their (mis)behavior is similar wrt SCHED_NORMAL tasks.
Because SCHED_FIFO is easier, _RR is for later. It was mostly an RFC to
request behavioural wishes from the users.
>
> > +#ifdef CONFIG_SCHED_HRT_TICK
> > +static int fifo_watchdog(struct rq *rq, struct task_struct *p, int queued)
> > +{
> > + if (likely(!queued || p->policy != SCHED_FIFO))
> > + return 0;
> > +
> > + /*
> > + * task has been naughty, turn into SCHED_NORMAL
> > + */
> > + printk(KERN_INFO "SCHED_FIFO task %s/%d exceeded his runtime quota,"
> > + " demoting to regular task\n", p->comm, task_pid_nr(p));
> > + deactivate_task(rq, p, 0);
> > + __setscheduler(rq, p, SCHED_NORMAL, 0);
> > + activate_task(rq, p, 0);
> > + resched_task(p);
>
> I guess, put_prev_task() / set_curr_task() should be called (for the
> case of task_running(p)) to make it group-scheduler-friendly (as it's
> done e.g. in sched_setscheduler()).
>
> (normilize_task() should probably do the same)
Right, that is where I copied from, I'll pull the functionality into a
single function and make this and the sysrq stuff use it.
Thanks!
Download attachment "signature.asc" of type "application/pgp-signature" (190 bytes)
Powered by blists - more mailing lists