[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20071017160327.GP5601@sgi.com>
Date: Wed, 17 Oct 2007 09:03:27 -0700
From: akepner@....com
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: Tony Luck <tony.luck@...el.com>,
Grant Grundler <grundler@...isc-linux.org>,
Jesse Barnes <jbarnes@...tuousgeek.org>,
Jes Sorensen <jes@....com>,
Randy Dunlap <randy.dunlap@...cle.com>,
Roland Dreier <rdreier@...co.com>,
James Bottomley <James.Bottomley@...eleye.com>,
David Miller <davem@...emloft.net>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/3] dma: add dma_flags_set/get_*() interfaces
[reply to the series of three mails below]
On Tue, Oct 16, 2007 at 08:27:28PM -0700, Andrew Morton wrote:
> On Tue, 16 Oct 2007 18:41:28 -0700 akepner@....com wrote:
>
> > +#define DMA_BARRIER_ATTR 0x1
> > +#ifndef ARCH_USES_DMA_ATTRS
> > +static inline int dma_flags_set_attr(u32 attr, enum dma_data_direction dir)
> > +{
> > + return dir;
> > +}
>
> This function takes an `enum dma_data_direction' as its second arg, but your
> ia64 implementation takes an 'int'.
>
This is because the dma_data_direction enum type isn't available
at the point the ia64 implementation is defined.
> > .....
> > dma_addr_t sn_dma_map_single(struct device *dev, void *cpu_addr, size_t size,
> > - int direction)
> > + int flags)
> > {
> > dma_addr_t dma_addr;
> > unsigned long phys_addr;
> > struct pci_dev *pdev = to_pci_dev(dev);
> > struct sn_pcibus_provider *provider = SN_PCIDEV_BUSPROVIDER(pdev);
> > + int dmabarrier = dma_flags_get_attr(flags) & DMA_BARRIER_ATTR;
>
> So we take an `enum data_direction' and then wedge it into a word alongside
> some extra flags?
>
> Can we do something nicer than that?
Changing the type of the last argument to dma_map_* functions
to be a bitmask? Or adding an additional argument? (Both of
which you mention below.)
> > .....
> > +DMA_BARRIER_ATTR would be set when the memory region is mapped for DMA,
> > +e.g.:
> > +
> > + int count;
> > + int flags = dma_flags_set_attr(DMA_BARRIER_ATTR, DMA_BIDIRECTIONAL);
> > + ....
> > + count = dma_map_sg(dev, sglist, nents, flags);
> > +
>
> Isn't this rather a kludge?
I prefer the term "hack".
>
> What would be the cost of doing this cleanly and either redefining
> dma_data_direction to be a field-of-bits or just leave dma_data_direction
> alone (it is quite unrelated to this work, isn't it?) and adding new
> fields/arguments to manage this new functionality?
It'd be significantly more work to do change or add arguments
to the dma_map_* functions. But if that's what I need to do to
get this accepted, I'll back up and have another go at it.
--
Arthur
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists