[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4772FE1E.3040401@zytor.com>
Date: Wed, 26 Dec 2007 17:21:34 -0800
From: "H. Peter Anvin" <hpa@...or.com>
To: Al Viro <viro@...IV.linux.org.uk>
CC: Pavel Machek <pavel@....cz>, Julia Lawall <julia@...u.dk>,
tglx@...utronix.de, viro@....linux.org.uk,
linux-kernel@...r.kernel.org, kernel-janitors@...r.kernel.org
Subject: Re: [PATCH 1/3] arch/x86: Use offsetof
Al Viro wrote:
> On Wed, Dec 26, 2007 at 05:01:38PM -0800, H. Peter Anvin wrote:
>
>> The right way to do it is:
>>
>> memset(&info.vm86plus, 0, sizeof info.vm86plus);
>
> If it's just one field _and_ we don't have padding we want to zero out -
> certainly...
It is - [comments removed for clarity]:
struct kernel_vm86_struct {
struct kernel_vm86_regs regs;
#define VM86_TSS_ESP0 flags
unsigned long flags;
unsigned long screen_bitmap;
unsigned long cpu_type;
struct revectored_struct int_revectored;
struct revectored_struct int21_revectored;
struct vm86plus_info_struct vm86plus;
struct pt_regs *regs32;
};
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists