[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20080218193611.GY22671@ca-server1.us.oracle.com>
Date: Mon, 18 Feb 2008 11:36:11 -0800
From: Mark Fasheh <mark.fasheh@...cle.com>
To: Julia Lawall <julia@...u.dk>
Cc: kurt.hackel@...cle.com, ocfs2-devel@....oracle.com,
linux-kernel@...r.kernel.org, kernel-janitors@...r.kernel.org
Subject: Re: [PATCH 3/6] fs/ocfs2: Use DIV_ROUND_UP
On Thu, Feb 14, 2008 at 04:15:17PM +0100, Julia Lawall wrote:
> From: Julia Lawall <julia@...u.dk>
>
> The kernel.h macro DIV_ROUND_UP performs the computation (((n) + (d) - 1) /
> (d)) but is perhaps more readable.
>
> An extract of the semantic patch that makes this change is as follows:
> (http://www.emn.fr/x-info/coccinelle/)
>
> // <smpl>
> @haskernel@
> @@
>
> #include <linux/kernel.h>
>
> @depends on haskernel@
> expression n,d;
> @@
>
> (
> - (n + d - 1) / d
> + DIV_ROUND_UP(n,d)
> |
> - (n + (d - 1)) / d
> + DIV_ROUND_UP(n,d)
> )
>
> @depends on haskernel@
> expression n,d;
> @@
>
> - DIV_ROUND_UP((n),d)
> + DIV_ROUND_UP(n,d)
>
> @depends on haskernel@
> expression n,d;
> @@
>
> - DIV_ROUND_UP(n,(d))
> + DIV_ROUND_UP(n,d)
> // </smpl>
>
> Signed-off-by: Julia Lawall <julia@...u.dk>
Acked-by: Mark Fasheh <mark.fasheh@...cle.com>
--Mark
--
Mark Fasheh
Principal Software Developer, Oracle
mark.fasheh@...cle.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists