[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.1.10.0805231133130.3081@woody.linux-foundation.org>
Date: Fri, 23 May 2008 11:57:51 -0700 (PDT)
From: Linus Torvalds <torvalds@...ux-foundation.org>
To: Jeremy Fitzhardinge <jeremy@...p.org>
cc: Ingo Molnar <mingo@...e.hu>, LKML <linux-kernel@...r.kernel.org>,
xen-devel <xen-devel@...ts.xensource.com>,
Thomas Gleixner <tglx@...utronix.de>,
Hugh Dickins <hugh@...itas.com>,
Zachary Amsden <zach@...are.com>,
kvm-devel <kvm-devel@...ts.sourceforge.net>,
Virtualization Mailing List <virtualization@...ts.osdl.org>,
Rusty Russell <rusty@...tcorp.com.au>,
Peter Zijlstra <a.p.zijlstra@...llo.nl>
Subject: Re: [PATCH 0 of 4] mm+paravirt+xen: add pte read-modify-write
abstraction
On Fri, 23 May 2008, Jeremy Fitzhardinge wrote:
>
> This series adds the pte_rmw_start() and pte_rmw_commit() operations,
> which change this sequence to:
>
> ptent = pte_rmw_start(mm, addr, pte);
> ptent = pte_modify(ptent, newprot);
> /* ... */
> pte_rmw_commit(mm, addr, pte, ptent);
Can you please rename these.
It's not a general "read-modify-write" operation on the PTE, and this
*only* works for changing protection details. In particular, you cannot
use pte_rmw_start/commit to change the actual page. So it's very much
about just protection bits.
It should probably also be called ptep_xyz(), since it takes a pte
pointer, not a pte.
So maybe calling it "ptent = ptep_modify_prot_start(..)" ...
"ptep_modify_prot_commit(..)" or something.
Linus
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists