lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 04 Jul 2008 10:29:12 -0600
From:	Zan Lynx <zlynx@....org>
To:	Ryan Hope <rmh3093@...il.com>
CC:	LKML <linux-kernel@...r.kernel.org>,
	Nick Piggin <nickpiggin@...oo.com.au>
Subject: Re: Lockless/Get_User_Pages_Fast causes Xorg 1.4.99.* to lock

Ryan Hope wrote:
> I have tested this with 2.6.26-rc5-mm3 and with 2.6.26-rc8 w/ the
> get_user_pages_fast patches from -rc5-mm3... Xorg 1.4.99.* will start
> to load but hangs at a black screen. At this point, I can not switch
> to another tty. When I try pressing ctrl+alt+del the kernel ooopses
> and the caps lock led starts to blink. This happens using the nv,
> radeon and radeonhd drivers (the nv was tested on another box
> obviously). I have also tried to unselect HAVE_GET_USER_PAGES_FAST in
> my kernel config but this does not help. I can not figure out where or
> what the bug is. I can provide any other info you guys need to figure
> this out. Let me know what I can do.


I think that I've seen this too on 2.6.26-rc8 on my laptop.  It's 64-bit 
AMD-64 single core (although I run a SMP-alternatives kernel on it) and 
I was using the nv driver.

The symptoms are the same.  Everything was working great until I started 
X.  I SSH'd in and got the dmesg after X locked up.  The full dmesg and 
config are attached because Thunderbird is a very stupid program and 
won't let me paste without wrapping.

Here is a bit of what I got though.

[  269.224276] BUG: unable to handle kernel paging request at 
ffffe20003480000
[  269.224291] IP: [<ffffffff80297e30>] copy_page_range+0x520/0x760
[  269.224306] PGD 1102067 PUD 1103067 PMD 0
[  269.224315] Oops: 0000 [1] SMP

[  269.224473] Call Trace:
[  269.224495]  [<ffffffff80239a9b>] dup_mm+0x26b/0x3c0
[  269.224507]  [<ffffffff8023a84c>] copy_process+0xc2c/0x1210
[  269.224518]  [<ffffffff8023aea3>] do_fork+0x73/0x310
[  269.224526]  [<ffffffff8024719e>] sys_rt_sigaction+0x8e/0xd0
[  269.224536]  [<ffffffff8020c2db>] system_call_after_swapgs+0x7b/0x80
[  269.224542]  [<ffffffff8020c5d7>] ptregscall_common+0x67/0xb0


View attachment "dmesg.log" of type "text/plain" (47465 bytes)

Download attachment ".config" of type "application/xml" (50685 bytes)

Powered by blists - more mailing lists