lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Tue, 8 Jul 2008 20:28:07 -0400
From:	"Mark Asselstine" <>
To:	"Alexander Beregalov" <>
Cc:	"Ian Romanick" <>,,,,
	"Linux Kernel Mailing List" <>
Subject: Re: [PATCH] drm_memory.h: remove double inclusion of linux/vmalloc.h

On Tue, Jul 8, 2008 at 12:56 PM, Alexander Beregalov
<> wrote:
> 2008/7/8 Ian Romanick <>:
>> On Tue, Jul 08, 2008 at 08:29:57AM -0400, Mark Asselstine wrote:
>>> On Sun, Jul 6, 2008 at 7:31 AM, Alexander Beregalov
>>> <> wrote:
>>> > From: Alexander Beregalov <>
>>> >
>>> >  #if __OS_HAS_AGP
>>> >
>>> > -#include <linux/vmalloc.h>
>>> > -
>>> Why remove this one and not the one at the top of the file? As well
>> I would assume this one is removed because it is inside additional
>> ifdefs.
> Yes, it does not change functionality of the code.

I guess I even question if this include should actually be anywhere in
this file.

>>> this file has #include of drmP.h, yet drmP.h is the only file I can
>>> find that includes drm_memory.h. Based on this I would think there is
>>> some additional cleanup that can go on here.
> How it can be cleaned up? Do you mean to move `define PAGE_AGP` to drmP.h?

It looks to me like this file at one time was meant to be included by
files other then drmP.h. Including drmP.h ensured __OS_HAS_AGP was
defined and a circular dependence was prevented by ifdefs surrounding
the bulk of drmP.h. As far as I can tell none of the includes in this
file are necessary anymore and a quick x86 compile seems to back me up
(please double check however). Once these are removed there is very
little functionality left and it might make more sense to just put in
into drmP.h. If in the future there is a need for this type of include
it can be started from scratch but for now I would say it should go

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists