[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20081103145514.GA23466@oksana.dev.rtsoft.ru>
Date: Mon, 3 Nov 2008 17:55:14 +0300
From: Anton Vorontsov <avorontsov@...mvista.com>
To: Dmitry <dbaryshkov@...il.com>
Cc: linux-kernel@...r.kernel.org, cbou@...l.ru,
Andrew Morton <akpm@...ux-foundation.org>
Subject: Re: [PATCH] power_supply: only register tosa_battery driver on tosa
On Sun, Nov 02, 2008 at 11:36:08PM +0300, Dmitry wrote:
> 2008/10/29 Dmitry Baryshkov <dbaryshkov@...il.com>:
> > There are already several wm97xx-battery drivers. Do register the tosa one
> > only on tosa machines.
> >
> > Signed-off-by: Dmitry Baryshkov <dbaryshkov@...il.com>
> > ---
> > drivers/power/tosa_battery.c | 3 +++
> > 1 files changed, 3 insertions(+), 0 deletions(-)
>
> What about this patch?
Sorry for the delay.
> IMO it can and should be merged during 2.6.28-rc cycle.
>
> diff --git a/drivers/power/tosa_battery.c b/drivers/power/tosa_battery.c
> index 2eab35a..4e52c22 100644
> --- a/drivers/power/tosa_battery.c
> +++ b/drivers/power/tosa_battery.c
> @@ -469,6 +469,9 @@ static struct platform_driver tosa_bat_driver = {
>
> static int __init tosa_bat_init(void)
> {
> + if (!machine_is_tosa())
> + return -EINVAL;
> +
I tend to reject this approach. You should rename the driver instead.
I.e.
-.driver.name = "wm97xx-battery",
-.driver.name = "tosa-battery",
And make sure that this won't break users of that driver (though
I don't see any).
> return platform_driver_register(&tosa_bat_driver);
> }
Thanks,
--
Anton Vorontsov
email: cbouatmailru@...il.com
irc://irc.freenode.net/bd2
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists