lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 3 Nov 2008 19:41:47 +0300
From:	Dmitry <dbaryshkov@...il.com>
To:	avorontsov@...mvista.com
Cc:	linux-kernel@...r.kernel.org, cbou@...l.ru,
	"Andrew Morton" <akpm@...ux-foundation.org>,
	"Mark Brown" <broonie@...nsource.wolfsonmicro.com>
Subject: Re: [PATCH] power_supply: only register tosa_battery driver on tosa

2008/11/3 Anton Vorontsov <avorontsov@...mvista.com>:
> On Mon, Nov 03, 2008 at 07:20:06PM +0300, Dmitry wrote:
>> 2008/11/3 Anton Vorontsov <avorontsov@...mvista.com>:
>> > On Sun, Nov 02, 2008 at 11:36:08PM +0300, Dmitry wrote:
>> >> 2008/10/29 Dmitry Baryshkov <dbaryshkov@...il.com>:
>> >> > There are already several wm97xx-battery drivers. Do register the tosa one
>> >> > only on tosa machines.
>> >> >
>> >> > Signed-off-by: Dmitry Baryshkov <dbaryshkov@...il.com>
>> >> > ---
>> >> >  drivers/power/tosa_battery.c |    3 +++
>> >> >  1 files changed, 3 insertions(+), 0 deletions(-)
>> >>
>> >> What about this patch?
>> >
>> > Sorry for the delay.
>> >
>> >> IMO it can and should be merged during 2.6.28-rc cycle.
>> >>
>> >> diff --git a/drivers/power/tosa_battery.c b/drivers/power/tosa_battery.c
>> >> index 2eab35a..4e52c22 100644
>> >> --- a/drivers/power/tosa_battery.c
>> >> +++ b/drivers/power/tosa_battery.c
>> >> @@ -469,6 +469,9 @@ static struct platform_driver tosa_bat_driver = {
>> >>
>> >>  static int __init tosa_bat_init(void)
>> >>  {
>> >> +     if (!machine_is_tosa())
>> >> +             return -EINVAL;
>> >> +
>> >
>> > I tend to reject this approach. You should rename the driver instead.
>> >
>> > I.e.
>> > -.driver.name    = "wm97xx-battery",
>> > -.driver.name    = "tosa-battery",
>> >
>> > And make sure that this won't break users of that driver (though
>> > I don't see any).
>>
>> The wm97xx-battery device is registered by
>> drivers/input/toucscreen/wm97xx-core.c
>
> Hmm.. So you can't rename the tosa driver, because then it won't
> work, correct?

Yup.
I see few ways to resolve this:
* write better wm97xx interface. Dunno if that is feasible or possible.
  One of the possible solutions is to pass battery and ts device names
  and data from within board data via ac97 layer to wm97xx-core. This
  will provide several benefits (e.g. then we can drop lots of parameters
  from wm97xx-core, which are really board parameters).
* Merge most of functionality of wm97xx-battery driver for Palms (by Marek),
  my tosa battery driver, name that The Only wm97xx-battery Driver. However
  on this path we will have to put lot's of code into hooks, which is
pretty much
  ugly IMO.


-- 
With best wishes
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists