lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 12 Nov 2008 08:04:26 -0500 (EST)
From:	Steven Rostedt <rostedt@...dmis.org>
To:	Ingo Molnar <mingo@...e.hu>
cc:	linux-kernel@...r.kernel.org,
	Andrew Morton <akpm@...ux-foundation.org>,
	Frederic Weisbecker <fweisbec@...il.com>,
	Theodore Tso <tytso@....edu>,
	Arjan van de Ven <arjan@...radead.org>,
	Steven Rostedt <srostedt@...hat.com>
Subject: Re: [PATCH] tracing: branch tracer, tweak output


On Wed, 12 Nov 2008, Ingo Molnar wrote:

> 
> a small detail:
> 
> > For example:
> >
> >  bash-3471  [003]   357.014755: [INCORRECT] sched_info_dequeued:sched_stats.h:177
> >  bash-3471  [003]   357.014756: [correct] update_curr:sched_fair.c:489
> >  bash-3471  [003]   357.014758: [correct] calc_delta_fair:sched_fair.c:411
> >  bash-3471  [003]   357.014759: [correct] account_group_exec_runtime:sched_stats.h:356
> >  bash-3471  [003]   357.014761: [correct] update_curr:sched_fair.c:489
> >  bash-3471  [003]   357.014763: [INCORRECT] calc_delta_fair:sched_fair.c:411
> >  bash-3471  [003]   357.014765: [correct] calc_delta_mine:sched.c:1279
> 
> it's always good to have such fields aligned vertically. Something 
> like this would be shorter and visually much easier to parse:
> 
>  bash-3471  [003]   357.014755: [ MISS ] sched_info_dequeued:sched_stats.h:177
>  bash-3471  [003]   357.014756: [ .... ] update_curr:sched_fair.c:489
>  bash-3471  [003]   357.014758: [ .... ] calc_delta_fair:sched_fair.c:411
> 
> any objections against the patch below which implements this?

How about "[  OK  ]" instead of "[ .... ]". That would be easier to 
understand.

-- Steve

> 
> 	Ingo
> 
> ----------->
> >From f88c4ae9f8c3939bee4337c75c7a673b5de7a8a7 Mon Sep 17 00:00:00 2001
> From: Ingo Molnar <mingo@...e.hu>
> Date: Wed, 12 Nov 2008 11:55:41 +0100
> Subject: [PATCH] tracing: branch tracer, tweak output
> 
> Impact: modify the tracer output, to make it a bit easier to read
> 
> Change the output from:
> 
> >  bash-3471  [003]   357.014755: [INCORRECT] sched_info_dequeued:sched_stats.h:177
> >  bash-3471  [003]   357.014756: [correct] update_curr:sched_fair.c:489
> >  bash-3471  [003]   357.014758: [correct] calc_delta_fair:sched_fair.c:411
> 
> to:
> 
> >  bash-3471  [003]   357.014755: [ MISS ] sched_info_dequeued:sched_stats.h:177
> >  bash-3471  [003]   357.014756: [ .... ] update_curr:sched_fair.c:489
> >  bash-3471  [003]   357.014758: [ .... ] calc_delta_fair:sched_fair.c:411
> 
> it's good to have fields aligned vertically, and the only important
> information is a prediction miss, so display only that information.
> 
> Signed-off-by: Ingo Molnar <mingo@...e.hu>
> ---
>  kernel/trace/trace.c |    4 ++--
>  1 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
> index 83d3863..728a46e 100644
> --- a/kernel/trace/trace.c
> +++ b/kernel/trace/trace.c
> @@ -1657,7 +1657,7 @@ print_lat_fmt(struct trace_iterator *iter, unsigned int trace_idx, int cpu)
>  		trace_assign_type(field, entry);
>  
>  		trace_seq_printf(s, "[%s] %s:%s:%d\n",
> -				 field->correct ? "correct" : "INCORRECT",
> +				 field->correct ? " .... " : " MISS ",
>  				 field->func,
>  				 field->file,
>  				 field->line);
> @@ -1808,7 +1808,7 @@ static enum print_line_t print_trace_fmt(struct trace_iterator *iter)
>  		trace_assign_type(field, entry);
>  
>  		trace_seq_printf(s, "[%s] %s:%s:%d\n",
> -				 field->correct ? "correct" : "INCORRECT",
> +				 field->correct ? " .... " : " MISS ",
>  				 field->func,
>  				 field->file,
>  				 field->line);
> 
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ