[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20090221110233.1baa9f5d@osiris.boeblingen.de.ibm.com>
Date: Sat, 21 Feb 2009 11:02:33 +0100
From: Heiko Carstens <heiko.carstens@...ibm.com>
To: David Daney <ddaney@...iumnetworks.com>
Cc: Martin Schwidefsky <schwidefsky@...ibm.com>,
Ralf Baechle <ralf@...ux-mips.org>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: Syscall wrappers breaks things.
On Fri, 20 Feb 2009 10:48:58 -0800
David Daney <ddaney@...iumnetworks.com> wrote:
> In commit ee6a093222549ac0c72cfd296c69fa5e7d6daa34 the syscall wrappers
> infrastructure was introduced.
>
> A typical definition is something like this (from Ralf's patch):
>
> SYSCALL_DEFINE6(32_ipc, u32, call, long, first, long, second, long, third,
> unsigned long, ptr, unsigned long, fifth)
> {
> .
>
> This creates a symbol sys_32_ipc. The old name of the symbol is
> sys32_ipc (note the change in the number of '_').
>
> For the mips64 kernel the syscall table for o32 ABI executable contains:
> PTR sys32_ipc
> This is now linked to the sys32_ipc function in kernel/sys_ni.c which
> kindly returns ENOSYS.
Sure, the SYSCALL_DEFINE macros work only for system calls that follow
the sys_[whatever] naming convention. In this case the original system
call should be renamed. E.g. sys_mips_ipc.
> The long and short of the problem is that the is now a kernel wide
> mismatch in function names between the names created by SYSCALL_DEFINE*,
> the syscall tables and kernel/sys_ni.c.
Only if the macros are used in a wrong way.
> I am not sure what the best solution is, but something should probably
> be done to un-break things.
Fix the patch that converts mips to system call wrappers ;)
Ralf's patch isn't in Linus' repository nor is it in linux-next. Or at
least I couldn't find it. So it looks like you're talking about some
private git tree?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists