lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 19 Apr 2009 17:59:54 +0900
From:	KOSAKI Motohiro <kosaki.motohiro@...fujitsu.com>
To:	Johannes Weiner <hannes@...xchg.org>
Cc:	Daisuke Nishimura <nishimura@....nes.nec.co.jp>,
	LKML <linux-kernel@...r.kernel.org>,
	linux-mm <linux-mm@...ck.org>,
	Andrew Morton <akpm@...ux-foundation.org>,
	Balbir Singh <balbir@...ux.vnet.ibm.com>,
	KAMEZAWA Hiroyuki <kamezawa.hiroyu@...fujitsu.com>
Subject: Re: [PATCH for mmotm 0414] vmscan,memcg: reintroduce sc->may_swap

Hi

Hi

>> @@ -1724,6 +1728,7 @@ unsigned long try_to_free_mem_cgroup_pag
>>       struct scan_control sc = {
>>               .may_writepage = !laptop_mode,
>>               .may_unmap = 1,
>> +             .may_swap = 1,
>>               .swap_cluster_max = SWAP_CLUSTER_MAX,
>>               .swappiness = swappiness,
>>               .order = 0,
>> @@ -1734,7 +1739,7 @@ unsigned long try_to_free_mem_cgroup_pag
>>       struct zonelist *zonelist;
>>
>>       if (noswap)
>> -             sc.may_unmap = 0;
>> +             sc.may_swap = 0;
>
> Can this be directly initialized?
>
> struct scan_control sc = {
>        ...
>        .may_swap = !noswap,
>        ...
> };

your proposal is better coding style. but I also prefer condig style
consistency.
I think we should change may_unmap and may_swap at the same time.
Thus, I'd like to does it by another patch.



>> @@ -2120,6 +2126,7 @@ unsigned long shrink_all_memory(unsigned
>>       struct scan_control sc = {
>>               .gfp_mask = GFP_KERNEL,
>>               .may_unmap = 0,
>> +             .may_swap = 1,
>
> shrink_all_memory() is not a user of shrink_zone() -> get_scan_ratio()
> and therefor not affected by this flag.  I think it's better not to
> set it here (just like sc->swappiness).

Will fix. thanks.



>>               .may_writepage = 1,
>>               .isolate_pages = isolate_pages_global,
>>       };
>> @@ -2304,6 +2311,7 @@ static int __zone_reclaim(struct zone *z
>>       struct scan_control sc = {
>>               .may_writepage = !!(zone_reclaim_mode & RECLAIM_WRITE),
>>               .may_unmap = !!(zone_reclaim_mode & RECLAIM_SWAP),
>> +             .may_swap = 1,
>
> Shouldn't this be set to !!(zone_reclaim_mode & RECLAIM_SWAP) as well?
>
> With set to 1, zone_reclaim() will also reclaim unmapped swap cache
> pages (without swapping) and it might be desirable to do that.

In general, you are right.
but another patch is better. this patch should only change memcg behavior.

I plan to change this. I'm making some zone reclaim test case, after it,
I can post the patch.


> But
> then may_swap is a confusing name.  may_anon?  may_scan_anon?
> scan_anon?

Why?
may_swap = 0 mean no swap-out directly. not anon only.
it's because shmem page stay in LRU_ANON.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ