[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090429112423.GA8813@elte.hu>
Date: Wed, 29 Apr 2009 13:24:23 +0200
From: Ingo Molnar <mingo@...e.hu>
To: Robert Richter <robert.richter@....com>
Cc: Peter Zijlstra <a.p.zijlstra@...llo.nl>,
Paul Mackerras <paulus@...ba.org>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 18/29] x86/perfcounters: rename cpuc->active_mask
* Robert Richter <robert.richter@....com> wrote:
> This is to have a consistent naming scheme with cpuc->used.
>
> Signed-off-by: Robert Richter <robert.richter@....com>
> ---
> arch/x86/kernel/cpu/perf_counter.c | 10 +++++-----
> 1 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/arch/x86/kernel/cpu/perf_counter.c b/arch/x86/kernel/cpu/perf_counter.c
> index 3f3ae47..9ec51a6 100644
> --- a/arch/x86/kernel/cpu/perf_counter.c
> +++ b/arch/x86/kernel/cpu/perf_counter.c
> @@ -29,9 +29,9 @@ static u64 perf_counter_mask __read_mostly;
> struct cpu_hw_counters {
> struct perf_counter *counters[X86_PMC_IDX_MAX];
> unsigned long used[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
> + unsigned long active[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
> unsigned long interrupts;
> u64 throttle_ctrl;
> - unsigned long active_mask[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
> int enabled;
better would be to change ->used to ->used_mask. That makes it sure
nobody does this typo:
if (cpuc->used)
it's a lot harder to typo this:
if (cpuc->used_mask)
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists