[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <4A5198A0.6030904@redhat.com>
Date: Mon, 06 Jul 2009 14:24:32 +0800
From: Amerigo Wang <amwang@...hat.com>
To: Arjan van de Ven <arjan@...radead.org>
CC: linux-kernel@...r.kernel.org, Jeff Mahoney <jeffm@...e.com>,
Yan Zheng <zheng.yan@...cle.com>,
Josef Bacik <jbacik@...hat.com>,
Chris Mason <chris.mason@...cle.com>,
akpm@...ux-foundation.org, linux-btrfs@...r.kernel.org,
Sven Wegener <sven.wegener@...aler.net>
Subject: Re: [Patch] btrfs: use file_remove_suid() after i_mutex is held
Arjan van de Ven wrote:
> On Mon, 6 Jul 2009 01:29:14 -0400
> Amerigo Wang <amwang@...hat.com> wrote:
>
>
>> file_remove_suid() should be called with i_mutex held,
>> file_update_time() too. So move them after mutex_lock().
>>
>> Plus, check the return value of kmalloc().
>>
>> Signed-off-by: WANG Cong <amwang@...hat.com>
>>
>> ---
>> diff --git a/fs/btrfs/file.c b/fs/btrfs/file.c
>> index 7c3cd24..cd36301 100644
>> --- a/fs/btrfs/file.c
>> +++ b/fs/btrfs/file.c
>> @@ -944,14 +944,17 @@ static ssize_t btrfs_file_write(struct file
>> *file, const char __user *buf, if (count == 0)
>> goto out_nolock;
>>
>> + mutex_lock(&inode->i_mutex);
>> +
>> err = file_remove_suid(file);
>> if (err)
>> - goto out_nolock;
>> + goto out;
>> file_update_time(file);
>>
>> pages = kmalloc(nrptrs * sizeof(struct page *), GFP_KERNEL);
>> + if (!pages)
>> + goto out;
>>
>>
> Hi,
>
> I don't think you can keep this at GFP_KERNEL once you hold i_mutex....
> very likely this needs to now turn into GFP_NOFS!
>
Good point!
Hmm, GFP_KERNEL adds __GFP_FS while GFP_NOFS not...
Just moving that kmalloc() up, before mutex_lock(), I think, can solve
this.
I will update this patch now...
Thanks!
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists